Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 2 of 2
  1. Thread AuthorThread Author   #1  
    donstar's Avatar
    iPhone Nanite

    1 Posts

    Default 3G power button always on

    The flex cable inside my 3G tore a while ago, resulting in the power button no longer working. I bought a new flex cable online and replaced the broken cable with the new flex cable. However, now my phone keeps on looping the Apple logo. I am able to get it out of the loop by plugging it into my computer, however after it is disconnected from the computer, it shuts off after the phone locks.

    Also, when the phone starts up after plugging it into the computer, the screen shows the red slide bar at the top, as if I had pressed the power button to power the phone off.

    I purchased a second cable, thinking that the first one was faulty, and the same thing happened.

    Thinking that the power button was somehow always being pressed, I experimented with one of the "good" cables, and cut the power button part of the flex cable off. Even with the power button cut off, it still does the apple loop, and it still acts as if the power button is always being pressed. I had to revert back to my original cable with the severed power button in order for the apple loop to stop (and to be able to use it without plugging it into my computer)

    any idea what might be going on? I'm running 3.1.2 on the phone now.
  2. #2  
    Tanbam's Avatar
    iMore Intermediate

    190 Posts


    Buy the flex cable from another vendor? It sounds like the ones you bought might have a short across the power pins. The connector that plugs into the logic board has very tight spacing between the pins. If the connector was put on a little crooked, it could easily cause this symptom.

    Look at the connectors under a magnifying glass and see if they're attached perfectly straight.

Posting Permissions