Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 1 of 1
  1. Thread AuthorThread Author   #1  
    dan_jaiii's Avatar
    iPhone Nanite

    1 Posts

    Default iPhone 3G: Do I need original carrier sim to unlock? (Ver. 2.2 | 02.28 Baseband)

    Dear TiPb Community,

    I'm running a Rogers iPhone 3G with firmware version 2.2 and baseband 02.28.00. It is currently unlocked, running on SmarTone-Vodafone in Hong Kong.

    The phone was unlocked when yellowsn0w just came out.

    Flashforward to today, and I'm wondering what's the best way to approach? I'm looking to upgrade my phone to take advantage of push notifications and new application updates.

    According to this redsn0w link (removed due to post count limitation), if my Iphone is "at 04.26 (baseband) or earlier, use a custom IPSW from PwnageTool to update your firmware to 3.1.2" with ultrasn0w.

    The problem though, is that PwnageTool is a Mac OS X only application. The docs also tell me to upgrade to iPhone 3.0 before I use it. Since this is already unlocked and I don't have the original carrier sim, is it safe to do a vanilla upgrade through iTunes?

    So I have a few questions:
    1. Is blackra1n, for iPhone 3G still a tethered only jailbreak?
    2. What are viable solutions for Windows? The ultrasn0w documention only refers to iPhone firmware 3.0?
    3. Finally, since this iPhone is from Rogers in Canada, and I no longer have a Rogers sim, do I need the original sim to successfully unlock it using whichever method?

    Thanks guys for the help! Gonna get back to researching!
    Last edited by dan_jaiii; 03-04-2010 at 04:53 AM.

Posting Permissions