Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. Thread AuthorThread Author   #1  
    gatorfan79's Avatar
    iPhone Beginner

    54 Posts

    Default can't download 4.2.6??

    Every time I sync my phone, it tells me to download and install the update... I've tried about 7 times, and every time it fails to download. It says something about the connection timing out - but I'm at home on my DSL connection (husband's phone dl'ed it just fine on his laptop). Could I have something set wrong? The only other thing running is Kaspersky anti-virus, could that be the problem?
  2. #2  
    shipwrestler125's Avatar
    iPhone Pro

    565 Posts
    Global Posts
    1,358 Global Posts


    I would try and do it without the anti-virus running and see if that works.
  3. #3  
    coltsbr's Avatar
    iMore Pro

    512 Posts
    Global Posts
    1,143 Global Posts


    I have the same anti-virus and had no problems downloading and installing.
  4. #4  
    jsntrenkler's Avatar
    iMore Elite

    2,635 Posts
    Global Posts
    3,958 Global Posts


    try rebooting your iPhone .. Hold the power button and home button down until you see the apple logo.
  5. #5  
    Uplink's Avatar
    iPhone Intermediate

    144 Posts


    I found a fix online for this. I had errors trying to install 4.2.6 too (error 1013). Try following these steps, I worded them easier to follow than what I had found originially:

    1: Open Terminal
    2: Copy and paste this - "sudo nano /etc/hosts" without the quotes
    3: Press Enter and type in your password
    4: Use the down arrow key to get to the IP address looking things. For me there were 3, the top and bottom ones had a "#" in front of it, and the middle did not.
    5: On the one without the "#", add one in front like the others
    6: After you have added the "#" in front the line that did not have it, press 'Control+O'. Then hit Enter
    7: Press 'Control+X'
    8: Try Restoring your iPhone. It will install the update and should work now

    1: Go to Start -> Programs -> Accessories
    2: Run Notepad or Wordpad
    3: Click open and browse to Windows/System32/drivers/etc
    4: In "Files of Type:" select all documents
    5: Open hosts
    6: Delete all line that has "gs.apple.com" or something similar to that
    7: Hit save
    8: Restore your device

    That should (will) fix the error. I have done the Mac way and it has worked.

Posting Permissions