1. Danwilliambiba's Avatar
    Hey all, i'm a volunteer who works with the deaf and i recently purchased an 8 Gig 3rd gen itouch in order to store all my ASL videos. It worked beautifully and played everything i needed exactly when i needed it.....then OS4 dropped. I figured why not, upgraded and wasn't' able to play videos. When i would select a video sometimes it wouldn't come up, or it would come up and i couldn't select anything, or the video would just continue to play no matter what i did. So i took it back to Best Buy and decided to get an upgraded one. They kicked me up to a 32 Gig no problem. i took the thing home and loaded all my videos, everything work perfectly again. I called apple and they said they had never heard of this happening and that if i upgrade again it will be fine...like an ***** i listened and the SAME thing happened. Video is the only reason i bought this thing and it's the only thing that doesn't work how i need it to. So i try to downgrade...unsuccessful, i call apple and spent 2 hours on the phone and nothing, thing still doesn't play videos. Anyone have any suggestion for me, because as of right now i have a 300 dollar paper weight. thanks
    08-25-2010 03:42 PM
LINK TO POST COPIED TO CLIPBOARD