1. Hello Kitty's Avatar
    I got the iPhone 4 about a month ago. Since then I have noticed that all my apps work great besides Facebook. It will close out on me and I have a super hard time uploading pictures. One day I had to remove and install Facebook 5 times to get it to work right.

    I go to upload pictures, and usually it will show on the bottom of the screen. The blue bar that shows it uploading. It shows nothing! Once I reinstall facebook, most of the time it takes care of the problem, but it seems as though I am reinstalling this app every week!

    Does anyone else have this issue? Do you think its more a network issue then it being my phone? I have Verizon Wireless. My bro has the same phone, but he has it through ATT and does not have these issues.

    Thanks!
    04-20-2011 11:39 AM
  2. kenh4495's Avatar
    I was rarely ever able to upload anything via the FB app directly. I just downloaded iloader app and no problems.
    04-20-2011 12:00 PM
  3. ebedoun's Avatar
    So strange. My sister-in-Law has the exact issues. Her iPhone is on Verizon as well.

    Just like you, reinstalling the app works for a bit, but that is it.

    The newest version of the FB app definitely compresses the photos when uploading also. I notice that they upload super fast on my at&t iphone 4. Also the file sizes are much smaller than they were before the latest FB app update.
    04-20-2011 01:17 PM
  4. eye4ni's Avatar
    *Try* enabling location services for Facebook in your iphone settings. I could not upload any pictures without this enabled. Once I enabled it I have not had a single issue.
    Gooster likes this.
    04-20-2011 01:25 PM
  5. Garz's Avatar
    Pictures not uploading could be due to poor network uploading speeds. This can be tested by downloading Speedtest app. When it has issues uploading, test your speeds
    04-20-2011 01:29 PM
  6. BreakingKayfabe's Avatar
    *Try* enabling location services for Facebook in your iphone settings. I could not upload any pictures without this enabled. Once I enabled it I have not had a single issue.
    This is EXACTLY what solved my pic uploading issue.
    04-20-2011 01:50 PM
  7. Kale58's Avatar
    *Try* enabling location services for Facebook in your iphone settings. I could not upload any pictures without this enabled. Once I enabled it I have not had a single issue.
    This is EXACTLY what solved my pic uploading issue.
    +1 Same thing here. Took me frickin' forever to find an answer, but that's what turned the trick.
    04-20-2011 04:58 PM
  8. BreakingKayfabe's Avatar
    The app was updated again today FYI
    04-20-2011 05:00 PM
  9. Kale58's Avatar
    The app was updated again today FYI
    Which means you "may" have to reset Location Services for it again....
    04-20-2011 05:06 PM
  10. yaynative's Avatar
    *Try* enabling location services for Facebook in your iphone settings. I could not upload any pictures without this enabled. Once I enabled it I have not had a single issue.
    The new Dropbox update requires location sharing as well to upload pictures.
    04-20-2011 06:25 PM
  11. Gooster's Avatar
    *Try* enabling location services for Facebook in your iphone settings. I could not upload any pictures without this enabled. Once I enabled it I have not had a single issue.
    That explains quite a bit! Had these issues myself! Thanks!
    04-20-2011 07:34 PM
  12. icehead13's Avatar
    I was wondering if it was the software acting buggy or was it a real problem. I hate that ****,not being able to load pics, and it closing for no reason. Never had that problem on my Evo.
    04-20-2011 10:26 PM
LINK TO POST COPIED TO CLIPBOARD