With iOS 8 Update both my Macs stopped using my phone number for iMessage.

TheINTJ

Member
Jun 22, 2013
8
0
0
Visit site
I noticed yesterday when I messaged a friend that the Messages App on my MBP had stopped using my phone number to send iMessages. Upon looking in the settings I realized that the number was no longer even showing up as an option for messages to be sent or received. When I got home I looked in the Messages App on my iMac to see the same exact scenario. The only thing I can think of that affected this was the update to iOS 8. Anybody know anything about this or has experienced the same thing?

I'm assuming maybe this is something that Apple temporarily put on hold until Yosemite is officially released. I can say that I was getting a ton of voice messages that would delete on the phone because of the settings in iOS 8, but since Messages in Mavericks isn't set up for them then they would just accumulate inside the app, so i'm not butthurt over it, but Messages is something I use A LOT on my computer and I'd rather not have double conversations going on everywhere.
 

TheINTJ

Member
Jun 22, 2013
8
0
0
Visit site
Make sure it is turned on with your phone


Sent from my Surface Pro 3 using Tapatalk

Thanks, I figured out the issue. It was because I didn't have iMessages on my phone signed in with my Apple ID. Once I signed it in it added my phone number back to all my devices.