WiFi Push Email from Exchange

Boise IT

New member
Dec 30, 2009
4
0
0
Visit site
Here is my question for anyone who may have an answer...

I have a 3gs on AT&T. Set up with an exchange server and all the DNS set up properly for internal and external email.

For some reason, I can not get PUSH to work when WiFi is turned on in conjunction with 3G/Edge BUT... If I turn on Airplane mode (essentially turning off my phone) and THEN turn on WiFi while Airplane mode is on, push notifications come in to my iPhone just fine. When I turn Airplane mode off, push stops working as well when WiFi is on.

I can still receive email with WiFi and 3G enabled, just have to go to my mailbox to get it to pull in.

With that said, it seems that when both WiFi and 3G/Edge are turned on at the same time then the iPhone will not receive push notifications. Am I in outer space here or does anyone else have this issue.

Seems like alot to worry about when all I want to use WiFi for is to remote control my AppleTV. :)

Thanks!
 

chobbs1

Well-known member
Mar 8, 2008
1,657
20
0
Visit site
This is a strange problem. Can you go through and tell us what your settings are? For example in the exchange account whatfolders do you have set to push etc...

You might want to delete that particular account and re-add it then run afew tests. My exchange account pushes to my phone no matter what network I am using.
 

Boise IT

New member
Dec 30, 2009
4
0
0
Visit site
Just pushing the main inbox. Deleted the account, ran some tests and the same results. I have read about others having the same type of problem as well.
 

Boise IT

New member
Dec 30, 2009
4
0
0
Visit site
Nope not jailbroken. Don't know what other details I can give.

When I am connected via WiFi ONLY (3G/Edge in airplane mode) push works great.

When I am connected to 3G/Edge ONLY (WiFi turned off) push works great.

When I am connected to 3G/Edge plus WiFi push doesn't work but I can go to the email account and it will fetch the email right away.

I re-setup the exchange account, nothing changes. Still all works (or doesn't work) the same.
 

chobbs1

Well-known member
Mar 8, 2008
1,657
20
0
Visit site
Hmm. Well I am at a loss. Hopefully some else reads this and comes up with somethin. If you do find what the issue is please share.

My next step would be to restore the phone as new. But you'll have to decide if that is worth it because you'll have re-add all your contacts/media/info. And you'll lose all the info in any games your currently playing