What's wromg with my iPhone?

Chloe Baker

New member
Sep 11, 2015
2
0
0
Visit site
I've had the io
Phone six for 9 months now it works perfectly until when I came to charge it, it wouldn't charge and it's now dead and still womt charge but e battery sign is showing ?
 

qbnkelt

Well-known member
Mar 17, 2012
5,213
5
33
Visit site
Make sure you're using the original cable. Also, leave it plugged in for a while.

What happens when you connect it to iTunes? Is it recognised?

Also how old is the device? Did you buy it new six months ago?
 

Chloe Baker

New member
Sep 11, 2015
2
0
0
Visit site
I don't the original cable but the cable works in all other phones, I have left it in h30 moms now and still nothing. Nothing comes up when I plug it into iTunes either and I bought it brand new about 9 months ago.
 

IAmSixNine

Well-known member
Oct 10, 2011
262
1
0
Visit site
The good news is you should still be under warranty. Lets just hope its not liquid damage or crap in the charging port.
Since the cable works fine with other devices lets focus on the phone.
Do you have an old tooth brush? Or maybe a tooth pick.
Grab those and maybe a small flashlight and try to clean inside your data port. Chances are you have something in there preventing it from either connecting in all the way, like lint build up. OR you have corrosion or something preventing the connectors from making contact.

After you have cleaned it plug it in for a while and see if it turns on or the battery plug in symbol comes on.
 

Trending Posts

Members online

Forum statistics

Threads
259,570
Messages
1,763,590
Members
441,181
Latest member
janinv23