Unable to send MMS to non-iphones

miller7796

Member
Sep 20, 2012
15
0
0
Visit site
I just switched to T-Mo from Google Fi last week and discovered over the weekend that I cannot send an MMS on an iphone 12. It works fine for other imessage users, but an MMS to Android or any other number that is not tied to imessage fails. The error message is attached stating that MMS needs to be enabled, but it is as you can see in the settings.

So far, I have removed the SIM and placed it back in the phone, reset network settings, turned off wifi, rebooted, toggled settings off and on and talked to both T-Mobile and Apple. Both blame the other. So here I am hoping maybe somebody else has experienced this and might have a solution. It's not a critical issue by any means, but it is frustrating going back and forth between T-Mobile and Apple.

error.jpg
settings.jpg
 

Annie_M

Moderator
Mar 2, 2016
21,972
782
113
Visit site
That's definitely frustrating. Could it be a space issue? You say that "it's frustrating going back and forth between T-Mobile and Apple". I assume that means you've been in touch with Apple and T-Mo support?
 

miller7796

Member
Sep 20, 2012
15
0
0
Visit site
That's definitely frustrating. Could it be a space issue? You say that "it's frustrating going back and forth between T-Mobile and Apple". I assume that means you've been in touch with Apple and T-Mo support?

I cannot imagine it is a space issue. I'm not even using half of the 128gb of storage on the device and have never really saved anything to icloud. Been in touch with both T-Mobile and Apple support, have open tickets with both.

Just went through and deleted a couple longer iMessage chains to see if that was it, but no luck there either. I might try to pick up a cheap pre-paid sim later tonight to do some testing. I feel like it's T-Mobile because it worked fine with Google Fi. I followed the network reset steps here a couple times as well. https://www.t-mobile.com/support/devices/apple/t-mobile-internet-and-mms-settings-apple-iphone
 

Annie_M

Moderator
Mar 2, 2016
21,972
782
113
Visit site
Just went through this and cleared out backed up photos. Now I'm using 36gb of 128gb, so storage should not be a concern, but still unable to send.

I appreciate the feedback!

Hopefully, someone else will come along that has some ideas for you. Please update us when you get it figured out.
 
Last edited by a moderator:

EdwinG

Ambassador
Mar 10, 2012
4,063
654
113
Visit site
I can’t help much, but have you checked your APN settings under “Cellular”, and then “Cellular Settings”.

There might be an SMS/MMS setting that’s not filled out.
 

miller7796

Member
Sep 20, 2012
15
0
0
Visit site
Update: picked up a prepaid Ultra Mobile SIM and was immediately able to send an MMS. The functionality stopped again once I put the T-Mo SIM back inside the phone. Thinking it's safe to say it is something with T-Mo.
 

miller7796

Member
Sep 20, 2012
15
0
0
Visit site
Update update: Now it's working as expected. Not sure whether it was deleting the plan out of my phone or de-registering my number from imessage and facetime, but all is good now. ¯\_(ツ)_/¯
 

Trending Posts

Members online

Forum statistics

Threads
260,338
Messages
1,766,473
Members
441,237
Latest member
Tomwex73