Unable to install High Sierra in Macbook Pro Mid 2012 13"

aviihmch87

New member
Nov 3, 2020
1
0
0
Hi Folks!

Hope you are staying safe!

I use a Macbook pro mid 2012 13" which is running Sierra 10.12.6 currently. Some spec about my mac (A1278) before I proceed to the issue:

8+8 GB DDR3 RAM

480 GB Crucial BX SSD (it is currently in Optical Bay, since my HDD flex cable is not working and the original HDD slot is empty).

i5 processor, 13" display (non retina)

So the issue is when I try to install Mac OS High Sierra or above (till Catalina), it takes 15-20 mins and then I see an error as 'An error occurred while trying to verify firmware' and not allowing me to pass the OS installation.

I tried directly installing from App store, tried via Bootable USB but for all the cases I get the same error. When I see that many people dont have troubles installing the latest OS (Catalina) in the Mid 2012 Version (Non Retina model), why am I having troubles in installing. I read in other forums that this might be due to APFS formatting of the disk but I dont get that option while formatting via Disk Utility as I use Sierra. Also, read as Mac will automatically update the firmware and format as APFS while moving to High Sierra.

Is it because I dont have a drive in my original HDD Bay is not allowing to update the firmware? Or could there be any other issues.

I badly in need of an OS update as the Office products and other Softwares aren’t compatible with Sierra and it is sometimes affecting my tasks.

Please help me guiding a solution for this.

Can someone help me on this?
 

Trending Posts

Forum statistics

Threads
255,774
Messages
1,747,145
Members
440,979
Latest member
MidnightRomance11xyUU