"This device isn't eligible..." error message WTF??

teach1love

Active member
Dec 16, 2011
38
0
0
Visit site
I am running a JB 4S 5.1.1. I went to update before I installed the new JB. I tried to update in DFU mode as well as through regular mode plugged in to ITunes. I havent tried OTA update. I kept getting, "Could not be updated because this device isnt eligible for the requested build". Does anyone know what this means and how to fix it?? Thanks