TELUS & iPhone 5 reception issues

Sparro

Member
Aug 4, 2012
10
2
0
Visit site
I have an iPhone 5 on TELUS and have noticed my reception is terrible. I had an iPhone 4 before the 5 as well as a BlackBerry and I always had 3 bars in my home and at work. Now with the iPhone 5 have have 1 bar consistently. My carrier version is 13.0.
Anybody else have these kind of issues? It's basically unusable and its very frustrating because a few weeks ago with my other phone it was terrific.
 

EdwinG

Ambassador
Mar 10, 2012
4,152
697
113
Visit site
Is your iPhone 5 on the LTE network (shows up as LTE on the top) or on the 3G (HSPA+) network?


If you're on LTE, it's normal as it is a brand new network, and the coverage is not perfect, but it improves weekly. I usually have between 2 to 3 bars in downtown Montr?al, but I get 15Mbit/s symmetric on that connection.
If you wish to use only the 3G (HSPA+)network, you can do so by going into "Settings", "General", "Cellular" and then set "Enable LTE" to the "off" position. The phone will then disconnect itself from the 4G-LTE network, and connect to the 3G (HSPA+) network, which takes approx. 2 seconds.
 

Sparro

Member
Aug 4, 2012
10
2
0
Visit site
It's on 3G. I live North East of the GTA (Toronto) and LTE is not built out in my area yet. I have LTE turned off for the most part.
There's something wrong with iOS6 or the iPhone 5 because my iPhone 4 and BlackBerry work perfect.
I actually have two iPhone 5's and they both behave exactly the same.
 

Trending Posts

Members online

Forum statistics

Threads
260,743
Messages
1,768,126
Members
441,263
Latest member
mjkradel