Speakerphone options driving me nuts

kingweb

Well-known member
Aug 6, 2010
249
1
16
Visit site
When I make or receive a call, and I want to use the speakerphone, I tap the speaker button, and it comes on.
However, VERY often, instead of switching on the speaker, it opens a menu with a choice of iphone, speaker, and ipad.

This is driving me nuts. I have disabled handoff as many websites suggest. I have calls on other devices turned off. I have wifi calling turned off.
I restart my phone, and the problem goes away. But then it comes back a while later, and then only way to get rid of it is restarting the phone.
I own an ipad, and I haven't used it in close to a year.

I don't know what else to do in order to disable this permanently.
I see lots of threads in various forms of people complaining about this, but no solution.
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,650
618
113
Visit site
Go to Settings → Phone → Calls on Other Devices and then either disable “Allow Calls on Other Devices” or disable the toggle next the listed items therein. Try disabling the toggle next to each individual item before turning off “Allow Calls on Other Devices.
 

kingweb

Well-known member
Aug 6, 2010
249
1
16
Visit site
Go to Settings → Phone → Calls on Other Devices and then either disable “Allow Calls on Other Devices” or disable the toggle next the listed items therein. Try disabling the toggle next to each individual item before turning off “Allow Calls on Other Devices.
Already did that a while ago, and it goes away. But then just randomly
Comes back. Only way to get rid of it is a restart.
 

Trending Posts

Members online

Forum statistics

Threads
259,710
Messages
1,764,129
Members
441,190
Latest member
Calion