[Solved] iPhone 4s Restoring firmware stuck 99.9%

wiqionline

Active member
Mar 25, 2012
25
2
0
Visit site
Hello geeks,
I have iPhone 4s with no luck of restoring to latest ios 8.2. When arrived to me it had 8.1.3 without GSM service (Blank Baseband).

Person who owned this phone told me that this is locked phone but unlocked with gevey sim till ios 8.1.2. He accidentally updated over wifi update to ios 8.1.3, then his phone turned into iPod. wifi, bluetooth worked correctly but no service of carrier. only Searching... whether sim inserted or not.
I decided to jailbreak but came to know there is no jailbreak available for 8.1.3. Read an article about jailbreaking 8.1.3 is to first update to 8.2 than jailbreak will be possible. So i updated to ios 8.2 and my phone stuck on activation screen with "error activating from apple server."
I thought it is technically right because there would be no baseband in that phone. gave it another try with restore/update to latest 8.2 firmware but now iPhone is stuck at restoring firmware at 99.9% every time.

Tried restoring from Recovery mode and also from DFU mode.

I am now totally out of luck. no firmware in it, no baseband in it. no option to downgrade back.

Any idea????

I noticed last time when phone was on 8.2 activation screen, sim tray was getting too much hot while spinning wheel to searching service.

Update

It will sound funny but some other places I heard about this trick and work for me like a charm on first attempt.

This is NAND writing which gets iphone to the boiling point and therefore last step of installing / restoring / updating firmware stucks.
Many people suggested to take iphone into the fridge / freezer to get chip cool. I was in office and tried another trick which suddenly came in mind as a last resort.

Switched Air conditioner ON at 18C (Least temperature), turned air swings (flap) at 90 degree angle downward to the chair where iphone placed on top of chair. Thus iphone got direct A/C's air for cooling purpose.

Kept that stuff about 15 minutes with powered off iphone.
After exactly 15 minutes, without turning ON iphone or without going into DFU mode, just plugged USB data cable into iphone for waking up and opened iTunes. iTunes detected as in recovery mode while iPhone display says also "connect to iTunes." holding Shift key and clicked Restore button, Called latest ipsw iOS 8.2 and waited to complete and voila!!!!!!!!

That's all folks. hope anyone gets help with this trick.
 
Last edited:

kch50428

Well-known member
Oct 22, 2010
21,025
305
0
Visit site
Re: iPhone 4s Restoring firmware stuck 99.9%

Try downloading the ipsw for your device to your computer, DFU mode - and point iTunes to the downloaded ipsw to restore.
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,642
618
113
Visit site
I don't "personally" advocate placing your iPhone in a freezer because as I see it, simply turning it off and then leaving it off for a while will in and of itself cause the device to cool. I've done mor restores than. Care to count and not once did I ever need to freeze my iPhone, even the few and rare times the restore process stalled or at least appeared to have stalled. I simply waited a few minutes and then restarted the process. All was well afterwards.
 

Latest posts

Trending Posts

Members online

Forum statistics

Threads
259,643
Messages
1,763,898
Members
441,187
Latest member
MayaMoss