prob with iphone 3G

diniro69

New member
Nov 25, 2008
4
0
0
Visit site
hi.....i accidentally downloaded the new iphone 2.2 software(from apple) to my jailbroken and unlocked(via sim adapter) iphone 3G(u.s. version),(was working properley), the phone has the message no service in the top left hand corner, i have since managed to re-install the 2.1 software back onto it, using quickpwn 2.1, but after many resets and trys, i can still get no signal, even with the old software back on!!, briefly after a reset i see the o2 signal appear for a couple of seconds and then deminish, does anybody have a fix for this or any help appreciated! i am on o2 network pay-as-u-go in the uk...just checked out the dev team web page, where it states iphone 3G customers should not download, until a another version of this unlock is available!!! doh....thanks 4 any replies,:eek:
 

jamesus

TiPb Forum Staff
Jul 10, 2008
1,818
11
0
Visit site
I might be posting out of turn here, but I do believe that the 2.2 firmware updates the baseband, which prevents the phone from being unlocked. The Dev Team sounds like they are close to unlocking the phone in the 2.1 firmware, but not for 2.2. I also believe that once the baseband is updated, it can not be rolled back by installing earlier firmware.

If any of this is incorrect, please someone correct me.
 

diniro69

New member
Nov 25, 2008
4
0
0
Visit site
apparently u are right,,, baseband upgrade has been installed, thus no more iphone...for the time being, maybe an unlock is in the pipeline for xmas?!! :mad:
 

amit85

Active member
Oct 6, 2008
35
1
0
Visit site
I am also using iphone 3g with turbo sim(sim adapter). One reason could be the above as mentioned by Jamesus. The other could be that may be the sim adapter is damaged. In order to update to 2.2 u must have taken out the sim and then connected with itunes for update. THis sim is suppose to be highly fragile and even a take out and then inserting back can damage it. When i bought the sim first time i ejected it to connect itunes and and tranfer some songs. I took utmost care wile ejecting, even then sim got damaged and either gave no signal or bland on the left upper part of the phone. Then i got a replacement of the sim and since then i have not ejected it. It has been 4 months and sim is working fine. So may be ur turbo sim is damaged.
 

Jeremy

Retired Moderator
Mar 27, 2005
6,807
251
0
www.iMore.com
i have a spare new sim adapter, inserted it but unfortunateley still the same problem!!

That's because 2.2 does not *currently* work with sim adapters.... simple as that. If anyone tells you different they are wrong.

"use of SIM-Proxies (small circuit boards/chips that sit underneath the SIM card) to provide GSM/UMTS service on your locked iPhone 3G is a method that we have always advised against. Early reports suggest that the 2.2 update disables the functionality of these devices. The techniques used were always unreliable and we are surprised that they have lasted this long."
 
Last edited:

Trending Posts

Members online

Forum statistics

Threads
260,343
Messages
1,766,488
Members
441,237
Latest member
Tomwex73