Not getting mail and app update alerts

mfranks985

Member
Mar 22, 2009
16
0
0
Visit site
Hello, just seeing if you guys can help me.

My 3gs isn't telling me when I receive new email or when the app store has a update for an app. Normally you get the alert sound and the red bubble showing the # of emails, and this isn't happening.

Push is turned on and set to 30 min, and i'm using a yahoo email account.

If i go into mail it then checks for mail, and if i go into the app store it shows if i have an update. It just isn't doing it on its own.

Text alerts work normally. What gives guys?

Thanks for any help.
 

Allyson Kazmucha

Well-known member
Apr 5, 2009
1,022
75
0
Visit site
Well for e-mail, do you have push or fetch set in your settings? If fetch is off, it won't work unless you go into the actual app. Push has to be enabled, then it will push it to your phone (given you have mobileme or yahoo or another supported push mail client)

As far as the app store, as far as I know the app store is not push notification enabled, so in order to see if you have updates, yes, you'll have to open the app store application.
 

mfranks985

Member
Mar 22, 2009
16
0
0
Visit site
Push is on and it is a yahoo account, so i SHOULD be double covered.

And if push is turned off i have fetch set for 30 min. One way or the other i should be getting my mail alerts.
 

Jeremy

Retired Moderator
Mar 27, 2005
6,807
251
0
www.iMore.com
More than likely a issue with Yahoo. It is notorious for not pushing... though you really can't complain if it's free. :(
 

Allyson Kazmucha

Well-known member
Apr 5, 2009
1,022
75
0
Visit site
More than likely a issue with Yahoo. It is notorious for not pushing... though you really can't complain if it's free. :(

Bad Ash is probably right. I've seen people post here and HoFo about that issue.

Have you tried a different e-mail on fetch even to see if it's yahoo that's causing an issue?
 

mfranks985

Member
Mar 22, 2009
16
0
0
Visit site
Bad Ash is probably right. I've seen people post here and HoFo about that issue.

Have you tried a different e-mail on fetch even to see if it's yahoo that's causing an issue?

No i have not tryed a differant email.
On a funny note it did just push on of my emails in.... but not both of them:confused:

It seems to work when it wants to :rolleyes:.
Its funny because it has always worked flawlessly on my ipod touch.
 

Allyson Kazmucha

Well-known member
Apr 5, 2009
1,022
75
0
Visit site
No i have not tryed a differant email.
On a funny note it did just push on of my emails in.... but not both of them:confused:

It seems to work when it wants to :rolleyes:.
Its funny because it has always worked flawlessly on my ipod touch.

Hm, sounds like a phone setting somewhere that's holding it up then.

I'm assuming you've deleted and re-added the account to see if that fixes anything?