No longer receiving group messages with T-Mobile

Beanz17

Member
Apr 5, 2017
5
0
0
Visit site
I have a 7 Plus and use T-Mobile. Recently I updated to iOS 10.3.1 (and 10.3.2 beta 5 today) and I can no longer receive messages from a group message if even one person is using an Android device. I restored the phone through iTunes several times and set it up as new but when I go to settings -> messages -> MMS/SMS, group message is completely missing. In the past I had the option to disable/enable group messaging but it's just not available at all. I went to an Apple store and they said it's an issue with T-Mobile and will be resolved when the next iOS update comes out. I really need group messaging to work because I rely on it for work and school but they said there is no option to downgrade back to iOS 10.2? I installed the iOS 10.3.2 beta 5 today because I was hoping that would fix it but nope. Does anyone have any suggestions or advice on what else I could do?
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,860
664
113
Visit site
It may very well be a T-mobile issue, but just in case it is not, did you put your iPhone in DFU mode prior to updating to iOS 10.3.1? Did you backup your iPhone via iTunes prior to upgrading? If so, did you attempt to restore from that backup? If not, give it a try to see if the group messaging option returns. If you did not put your device in DFU mode prior to upgrading, go ahead and do so if you have the time. Also, delete the existing ipsw file from your computer. What you want is for iTunes to download and install a fresh full copy of iOS 10.3.1. Hopefully, the group messaging option will re-appear. If so, you can then re-install the beta profile and do an OTA upgrade to the current iOS beta, if you want. If the group messaging option does not re-appear then yeah, it's more than likely a T-mobile issue.
 

TwitchyPuppy

Moderator
Jun 3, 2015
5,872
8
38
Visit site
I doubt it's a T-Mobile issue.

My "group messaging" setting was gone after iOS 10.3.

It's now called "MMS Messaging", which is literally the same thing. Try activating it ;)
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,860
664
113
Visit site
I doubt it's a T-Mobile issue.

My "group messaging" setting was gone after iOS 10.3.

It's now called "MMS Messaging", which is literally the same thing. Try activating it ;)

Are you on T-mobile's network? I'm not and I still have the "Group Messaging" option on my iPhone running the current beta.

IMG_0191.JPG
 

Beanz17

Member
Apr 5, 2017
5
0
0
Visit site
Yep! I put it in DFU mode a lot of times and restored it through iTunes that way.

Just_Me_D - I literally tried everything you suggested but no, it didn't appear again. I did talk to T-Mobile but to be honest I can't switch to a different carrier right now and I liked T-Mobile and was happy with them until my group messaging disappeared.

Twitchy - I have MMS enabled but it's just in that one screenshot that Just_Me_D posted. My group messaging option disappeared. I can send a group message to people with Android but it's useless because I can't reveive anything from them once they reply. I can send a text to everyone individually but I seriously regret updating my software now. Apple said they'd fix it with the new update and T-Mobile is relying on them to fix it (the Apple store said it must be a code error in the software update). But when I installed the iOS 10.3.2 beta 5 it is still not fixed so I'm worried it won't be fixed at all for a while
 

Ledsteplin

Ambassador
Oct 2, 2013
50,436
724
108
Visit site
Yep! I put it in DFU mode a lot of times and restored it through iTunes that way.

Just_Me_D - I literally tried everything you suggested but no, it didn't appear again. I did talk to T-Mobile but to be honest I can't switch to a different carrier right now and I liked T-Mobile and was happy with them until my group messaging disappeared.

Twitchy - I have MMS enabled but it's just in that one screenshot that Just_Me_D posted. My group messaging option disappeared. I can send a group message to people with Android but it's useless because I can't reveive anything from them once they reply. I can send a text to everyone individually but I seriously regret updating my software now. Apple said they'd fix it with the new update and T-Mobile is relying on them to fix it (the Apple store said it must be a code error in the software update). But when I installed the iOS 10.3.2 beta 5 it is still not fixed so I'm worried it won't be fixed at all for a while

Just because the beta didn't fix it doesn't mean the public release will not. There may even be another beta release that may include it. Was T-mobile aware of the problem when you called?
 

Beanz17

Member
Apr 5, 2017
5
0
0
Visit site
Yeah, that's what I'm hoping :) It's immensely frustrating. T-Mobile didn't seem to be aware and most of my friends who also have T-Mobile didn't even notice until I asked them about it and then they realized that it's also not working for them. They called T-Mobile as well but T-Mobile said it's an error on Apple's side so they couldn't really help me out. I asked at the Apple store if they could replace my phone with another one that runs a previous iOS version but they said they couldn't because it's not a hardware issue and because a new phone would also run iOS 10.3.1
 

ravenseb

Well-known member
Oct 5, 2015
448
0
16
Visit site
0bdc1ebb24f70b9b0a150184b4e3e90a.png
im in the latest beta and group messaging works flawless for me and I'm on T-mobile
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,860
664
113
Visit site
Yep! I put it in DFU mode a lot of times and restored it through iTunes that way.

Just_Me_D - I literally tried everything you suggested but no, it didn't appear again. I did talk to T-Mobile but to be honest I can't switch to a different carrier right now and I liked T-Mobile and was happy with them until my group messaging disappeared.

Oh okay. Hopefully, a fix is forthcoming soon. Thanks for trying the procedure and I'm sorry it didn't solve the problem, but on the bright side, at least you have a smooth running device...
 

Ledsteplin

Ambassador
Oct 2, 2013
50,436
724
108
Visit site
Yeah, that's what I'm hoping :) It's immensely frustrating. T-Mobile didn't seem to be aware and most of my friends who also have T-Mobile didn't even notice until I asked them about it and then they realized that it's also not working for them. They called T-Mobile as well but T-Mobile said it's an error on Apple's side so they couldn't really help me out. I asked at the Apple store if they could replace my phone with another one that runs a previous iOS version but they said they couldn't because it's not a hardware issue and because a new phone would also run iOS 10.3.1

Have you tried Reset All Settings?

Go to Settings >General >Reset >Reset All Settings. This resets to default everything in Settings, including notifications, alerts, brightness, and clock settings like wake up alarms.
 

Beanz17

Member
Apr 5, 2017
5
0
0
Visit site
Have you tried Reset All Settings?

Go to Settings >General >Reset >Reset All Settings. This resets to default everything in Settings, including notifications, alerts, brightness, and clock settings like wake up alarms.

Thank you! I just tried that but now my MMS disappeared too ... it's weird. My phone is unlocked so I put in a friend's AT&T's SIM card just now and it works fine with group messaging. It even shows up again and all so it has to be related to T-Mobile. Ugh.
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,860
664
113
Visit site
Thank you! I just tried that but now my MMS disappeared too ... it's weird. My phone is unlocked so I put in a friend's AT&T's SIM card just now and it works fine with group messaging. It even shows up again and all so it has to be related to T-Mobile. Ugh.

Go to your local T-mobile store and have them exchange your SIM card.
 

pkcable

Q&A Team Leader, VR Expert
Moderator
Jun 16, 2009
5,827
28
0
Visit site
I'm on T-Mobile and I also have no issues with group messaging. I'm also on the latest regular release 10.3.1.