• Welcome to the all-new iMore Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

My iphone 4 no longer plays music in my car via auxillary port

jcrausch

New member
Jun 24, 2014
2
0
0
I was using an auxiliary cable to play music in my truck successfully for several weeks when it mysteriously stopped working. I drive a 08 Chevy Silverado equipped with an auxiliary jack. I have tried another Iphone4 of the same type with the same OS and it works without issue. I would normally listen to Pandora all day, so this has become a frustrating problem. :confused:Note-

- The phone plays music through its own speakers, home stereo and headphones
- I have tried switching cables that also work with alternate phones of the same type and OS
- I have tried resetting my settings on the phone in question to no avail
- I am certain that the stereo has the 'auxiliary' option selected
- The volume is indeed turned up everywhere possible, itunes, the stereo itself, Pandora, the phone etc
- I have not recently updated the OS
- The phone played music from my list as well as Pandora and other listening venues perfectly for several weeks with no problems whatsoever

This problem is eating at me and I appreciate any info anyone might provide- Thanks!!

[car][truck][speakers][auxiliary][cable][play][music]
 

kataran

Ambassador
Mar 11, 2013
4,659
12
38
Welcome to iMore jcausch

If your able to use headphones it appears your phone jack is working properly and the other iPhone clears any problems with your trucks auxiliary jack. The only thing that it could be is the cable

This one has stumped me. Hopefully someone else can bring more light to your problem
 

jcrausch

New member
Jun 24, 2014
2
0
0
Yes, it has me stumped as well. I have tried changing the cable, which works fine with a phone of the same type and OS. I did some amount of searching posts on a number of sites to troubleshoot the problem. As far as I can tell, the only things I have yet to try are doing a restore through itunes, which would erase all my text records- not an option for me. Then I also might try disconnecting the truck battery to reset all its systems so that it might recognize my phone again- not wild about that option either as it might reset the truck settings for oil life, brake life, engine usage etc.
Thanks for the reply anyway kataran, i'll post any progress for those poor souls that might be stumped as well
 

kataran

Ambassador
Mar 11, 2013
4,659
12
38
Yes, it has me stumped as well. I have tried changing the cable, which works fine with a phone of the same type and OS. I did some amount of searching posts on a number of sites to troubleshoot the problem. As far as I can tell, the only things I have yet to try are doing a restore through itunes, which would erase all my text records- not an option for me. Then I also might try disconnecting the truck battery to reset all its systems so that it might recognize my phone again- not wild about that option either as it might reset the truck settings for oil life, brake life, engine usage etc.
Thanks for the reply anyway kataran, i'll post any progress for those poor souls that might be stumped as well

Thanks for the reply

If you back up your device thru iCloud you will not loss your text messages if you choose to go that route but I don't see a restore fixing this unusual problem

Have you considered a Bluetooth speaker that's what I use for music and call answering in my vehicle