My ID password no longer works, how do I get into my phone?

I

iMore Question

My ID password no longer works

Ok so I have the cloud set up on my 4S, recently changed broadband provider and was told my email address would be deactivated so had to transfer to other accounts and change my email addresses for everything so that's what I did. I logged on to the apple website and changed my email for my apple ID, however now when I try to download from the app store or do anything else requiring my ID it pops up with Apple ID or password incorrect. In hindsight I should've deleted the account on my phone before changing it online but I can't go back in time so any help would be great.
I tried on the phone to add a new icloud account with the new email address but the pop up said it was already added, I have tried iforgot to try and find the account but it says No Apple ID found, this is really frustrating as it seems that it is only the one account on my phone but using the old address and I can't change or delete the address on the phone as it won't accept the password which I know is correct, in usage it says storage details are currently unavailable, I have also tried software update and resetting the phone but again it wants the password which it won't accept, not sure where to go from here, is there any point going to an apple store?
 

Trending Posts

Forum statistics

Threads
259,613
Messages
1,763,765
Members
441,187
Latest member
97Shenae59