Jailbreak does not work

kamakuiproject

New member
Apr 29, 2009
3
0
0
Visit site
On a 3G iPhone (using a late 2007 or early 2008 iMac with OS X 10.5.6), I have successfully entered DFU mode but as I do, while holding my iPhone power button, at the 9 second mark, my iTunes pops up, and tells me:

An iPod has been detected, but it could not be identified properly. Please disconnet and reconnect the iPod, then try again. An unknown error occurred (2001).​

Now, while PwnageTool tells me I have successfully entered DFU mode, I have a black-screened iPhone (I know how to get it back to un-jailbroken, non-DFU mode state), and if I quit and restart iTunes, it does not recognize the phone.

Am I supposed to "Restore" from here? If I press the Alt/Option key when iTunes is up and running, I get nothing. If I re-try and press it when I am opening iTunes, I get a chance to build a new iTunes off a new Library (not what I am trying to do). I have not been able to find a "Restore" button to click.

Any help available?
 

kamakuiproject

New member
Apr 29, 2009
3
0
0
Visit site
Found it. Jailbreaking on 10.5.6 requires a workaround

Now it works.

I ran into the OS X 10.5.6 problem.
My jailbreak worked ONLY after I plugged my iPhone into a USB hub, and then plugged the USB hub into the iMac.

If you have OS X 10.5.6, one procedure which may work:
1) Plug iPhone into USB hub, plug USB hub into Mac.
2) Run PwnageTool for 2.2.1
3) Achieve DFU mode.
4) iTunes starts up, press Alt-Option, to get Recovery button
5) Restore

Post #99 on the front page of this jailbreak site describes the issue.
 

Trending Posts

Members online

Forum statistics

Threads
259,655
Messages
1,763,953
Members
441,186
Latest member
LucasEMS