iTunes v8 and iPhone v1.1.4

sangjahat

New member
Sep 24, 2008
1
0
0
Visit site
im using iPhone 1.1.4 (jailbroken) and planning to install the latest iTunes. will it work with my phone or shall i just maintain the older version? i read somewhere that if i were to use v8 on my 1.1.4 it wont be able to back up my phone..

appriciate your feedback on this. thanks!