iPod Touch issues w/ BMW iDrive? Is it iPod size or higher iOS versions?


Well-known member
Sep 27, 2012
I’ve been using a 32gb iPod Touch 6th generation in my 2018 540 since I got it. It has worked flawlessly.

In preparation for our new 2019 X5 (which will replace our 2016 X5), I got another iPod Touch 6th generation to replace the older iPod we were using in the X5. New new iPod is 128gb because the older one was almost full, so I planned to use the bigger iPod in the 540.

The new one works terribly both in our X5 and in the 540. It is laggy to respond to inputs/changing the song and artwork sometimes takes a long time to appear—if it all.

At first I thought it might be slow because iDrive was re-indexing the new device for voice recognition. However, after two days, it is still behaving the same way.

I tried both iPods back to back in the X5 and the behavior was the same. The 32gb iPod works quickly immediately. The bigger one is laggy.

Other than the size, the only other difference is that the older iPod is running iOS 10.3.3. The newer one is on iOS 11. (I never upgraded the older one because it was working perfectly and I figured I’d leave well enough alone. Perhaps I was on to something!).

Has anyone else seen this issue? Could it be that iDrive doesn’t respond well to the bigger iPod? Or is it iOS 11?

Unfortunately, it is no longer possible to downgrade to iOS 10 on the iPod (please correct me if I’m wrong, as I’d try that), so I’m going to try upgrading it to iOS 12 to see if that makes any difference.

Any insights or ideas would be appreciated.



Ambassador Team Leader, Senior Moderator
Jan 8, 2012
I don't have a BMW, but is there an available firmware update for the vehicle that may improve the performance in regard to the newer iPod touch running iOS 11? You've already stated that you're going to upgrade it to iOS 12 to see if that makes a difference. Have you done that yet?


Well-known member
Sep 27, 2012
I did upgrade to iOS 12. It made it a little more responsive, but I'm getting periodic resets. Vehicle firmware is up to date.

It is odd since, again, the 32gb iPod Touch I have (running iOS 10) works flawlessly in both of our BMWs.

Thinking maybe it does not like the larger capacity. I spent some time at the Apple Store yesterday and a very helpful guy there looked into it but could find no info. Suggested perhaps swapping this 128gb model for a 32. I'm also checking with friends to see if anyone has an old one sitting around that I might be able to try with an earlier OS.

Strange indeed....

Trending Posts

Forum statistics

Latest member