Iphone Stuck in Emergency Call Screen after 3.0 upgrade, Power Button not working


New member
Jul 12, 2009
Visit site
I really need some help i will try my best to describe this problem i am having with my 2g 8gig iphone.

1. Updated my iphone to firmware 3.0 via itunes and from that point the power button does not seem to work, when pressing i hear the clicking sound but the slide to power off does not come up.

2. I tried restoring and it goes as far as when the logo of the usb and itunes comes up and I am able to restore firmare back to 3.0 but unable to downgrade to any other firmware as i keep getting error 20 when i try (firmware 2.0 etc)

3. I tried letting the battery drain completely and recharging but nothing happens, tried all the information about placing in recovery mode and nothing works, seems impossible to put in Dfu mode because the power button does not seem to be working at all so i keep getting errors and i also tried this Dfu software that you install to the root of your hard drive and still no luck.

At this point all the iphone does is go into emergency call mode and recovery mode and other times it just basically keeps restarting and displaying the apple logo.

Any help is appreciated i just want to know if i should just call it quits because the iphone is beyond repair, or if there is any hope at all

Trending Posts

Forum statistics

Latest member