iPhone screen becomes unresponsive at least 5x a day. Whats going on?

Larzo#IM

Well-known member
Jun 18, 2009
118
0
0
Visit site
I love my iPhone aside from this annoying little problem. Sometimes when I'm using it, no matter what I'm doing (texting, games, browsing), the iPhone screen becomes completely unresponsive. The home and lock button work, but the screen itself wont respond to touch. The only solution to it is to lock the phone and then unlock it, which is proving to get pretty tedious. It acts up like this at least 5x a day, more some days. Does anyone know if this is a hardware or software isue, and should I take it in to Apple? Any input is appreciated.
 

Jeremy

Retired Moderator
Mar 27, 2005
6,807
251
0
www.iMore.com
First thing I would try is a restore to new iPhone. If you still then have an issue, it's obviously a hardware issue and that's when you bring it into an Apple Store.
 

h4rk

Well-known member
Feb 23, 2009
52
0
0
Visit site
Are you jailbroken? Before 3.0, I was jailbreaking my 3G which caused stability and performance issues. Even my girlfriend who only uses my iPhone occasionally to check an email or something while she is away from her computer noticed, saying that the touch screen was occasionally unresponsive and load times were longer. I held out and once 3.0 came out, I went back to the regular iPhone software which has helped tremendously.
 

Larzo#IM

Well-known member
Jun 18, 2009
118
0
0
Visit site
Are you jailbroken? Before 3.0, I was jailbreaking my 3G which caused stability and performance issues. Even my girlfriend who only uses my iPhone occasionally to check an email or something while she is away from her computer noticed, saying that the touch screen was occasionally unresponsive and load times were longer. I held out and once 3.0 came out, I went back to the regular iPhone software which has helped tremendously.

Nope, not jailbroken. 3 week old 32GB 3GS.
 

Larzo#IM

Well-known member
Jun 18, 2009
118
0
0
Visit site
First thing I would try is a restore to new iPhone. If you still then have an issue, it's obviously a hardware issue and that's when you bring it into an Apple Store.

I'll give that a try. When I load all of my stuff back on, will I lose my icon placements?
 

cobra302

Well-known member
Sep 24, 2008
571
7
0
Visit site
my 3G has done this same thing (only lock and home buttons work) twice. each time it has freaked me out! i tried everything, and finally put it on vibrate, then back and that made it work again. weird. mine has only done it twice though. not all the time like yours.
 

Larzo#IM

Well-known member
Jun 18, 2009
118
0
0
Visit site
If I sync my stuff and choose to restore to a new phone. How do I go about getting my saved backed up stuff back on my iPhone. Also, will I lose texts?
 

Tramain

Well-known member
May 7, 2009
3,336
18
0
Visit site
If I sync my stuff and choose to restore to a new phone. How do I go about getting my saved backed up stuff back on my iPhone. Also, will I lose texts?

Yes you will lose text messages. You can save your pictures and apps on your PC/MAC thought.
 

ryrycalguy

Well-known member
Jul 14, 2008
60
18
0
twitter.com
Did you by any chance, restore your new 3GS from an old iPhone that wasn't on OS 3.0 yet? If so, that could also be the problem. I've had a couple of friends who lined up to buy the new iPhone and went home and restored their new iPhones from a back-up file from a previous iPhone that didn't have OS 3.0 installed on it yet. They used to have this problem too. They backed-up their phone again under 3.0, then restored their new iPhone again and used the back-up file from their 3.0 version. I don't hear them complaining anymore.

Either that or it's just a hardware issue.
 

Larzo#IM

Well-known member
Jun 18, 2009
118
0
0
Visit site
Did you by any chance, restore your new 3GS from an old iPhone that wasn't on OS 3.0 yet? If so, that could also be the problem. I've had a couple of friends who lined up to buy the new iPhone and went home and restored their new iPhones from a back-up file from a previous iPhone that didn't have OS 3.0 installed on it yet. They used to have this problem too. They backed-up their phone again under 3.0, then restored their new iPhone again and used the back-up file from their 3.0 version. I don't hear them complaining anymore.

Either that or it's just a hardware issue.

Nope, this is my first iPhone. Havent tried the restore/backup yet, I havent had time.