iPhone Refuses to restore from backup after iPhone OS 3.0 -Please Help!

F.N.H

New member
Jul 13, 2009
2
0
0
Visit site
I have a 3G iphone that I backed up on iTunes and then installed OS 3.0. I tried to restore from the back up but it refused to giving me the error message 14. Additionally my phone is locked and I am unable to use it except to make emergency calls.

P.S. It's unlocked!
 

h4rk

Well-known member
Feb 23, 2009
52
0
0
Visit site
If you had jailbroken/unlocked and performed an install of 3.0 your phone may be messed up. It's usually a good idea to restore to legit iPhone software before installing a new update, at least that's what I did back when I jailbroke mine. I don't really know what else to tell you because I'm not really an expert on jailbreaking. Sorry!
 

F.N.H

New member
Jul 13, 2009
2
0
0
Visit site
Could I use an legit AT&T SIM card to boot up the iPhone, and then re jailbreak the iPhone? Also, what about my backed up data?
 

BradM73

Well-known member
Sep 11, 2008
265
6
0
Visit site
You don't need a SIM card to boot the phone, jailbreak or unlock.

It sounds like you had the same problem that I had when I upgraded my 3G. What I did was restore to a like-new phone, then I didn't have any problems. If you are getting the screen with the USB cable on it, then it just needs to be synced with iTunes for activation. This took a few tries with my 3G as the Apple servers were really busy at the time. I wish you luck though. If all else fails, call Apple support, they'll probably have to up and going in no time (or at least under two hours).
 

Latest posts

Trending Posts

Members online

No members online now.

Forum statistics

Threads
260,349
Messages
1,766,517
Members
441,240
Latest member
smitty22d2