iPhone only connects on 3G

deanoelsch

New member
Jul 7, 2009
3
0
0
Visit site
Hi, could someone please help as I am going mad. My iPhone only connects when a 3G network is available. If I turn 3G off in a 3G area it even says no service and when I leave town, it has no service for hours... Pain in the A$$. Is this a software/settings issue or is my aerial stuffed? Thanks
 

Savio

Active member
Jul 7, 2009
30
1
0
Visit site
Hopefully it's just a software issue and there's nothing physically wrong with the phone. Try these things first:

Reset Network Settings: Settings > General > Reset > Reset Network Settings

Hard reset: Press and hold home + sleep/wake (power) button until device shuts down and you see an Apple logo.

If nothing else works, I'd try a restore and set it up as a new phone. If your phone is STILL having issues, it sounds like it's definitely a hardware issue and I'd look into getting it replaced.
 

deanoelsch

New member
Jul 7, 2009
3
0
0
Visit site
Tried all of those

Yip tried both those options... It still isn't helping which is why I fear it is hardware. However, it makes no sense that 3G is fine but normal signal isn't. Are there 2 different aerial types in the phone? One for 3G and one for normal reception? Thanks for the reply though!
 

Savio

Active member
Jul 7, 2009
30
1
0
Visit site
By "aerial" am I correct in assuming you're talking about the 3G and EDGE radios? If so, the iPhone has two separate radios for 3G and EDGE if I'm not mistaken. At this point, I'd try restoring in iTunes.
 
Last edited:

deanoelsch

New member
Jul 7, 2009
3
0
0
Visit site
Correct, radio bands then. Sorry, not down with the terminology. I think it's hardware then as I have restored it, loaded the new software, reset everything and still not luck... I guess its going in for repairs then :-(
 

Trending Posts

Members online

Forum statistics

Threads
259,668
Messages
1,764,001
Members
441,188
Latest member
Remona94B9