iPhone 6 Faulty Wi-Fi?

NekoMichi

Well-known member
Sep 9, 2014
66
0
6
Visit site
A couple of days ago the Wi-Fi on my iPhone 6 suddenly stopped working properly and exhibited a wide range of symptoms, I was wondering if anyone knows the cause? Here's the list of effects.

If iPhone attempts to connect to a passworded home network (tested on multiple private networks):
- It fails to connect, saying the password is wrong, however retrying without retyping the password eventually will cause it to connect.
- It connects and the Wi-Fi icon appears in the status bar, however no apps are able to access the Internet. Other devices can connect to the same network and access the Internet normally.
- Occasionally, iPhone can connect to a passworded home network fine and use the Internet normally without exhibiting the above signs.

If iPhone attempts to connect to a non-passworded public network (tested on multiple public networks):
- It loads for a while, then says "unable to connect".
- It stays on the loading screen indefinitely and never connects.
- It connects and the Wi-Fi icon appears in the status bar, however no apps are able to access the Internet. Other devices can connect to the same network and access the Internet normally.

If iPhone attempts to connect to a public network with a login page (tested on multiple public networks):
- It appears to connect under the settings menu, but the login page never appears, and the Wi-Fi icon never appears in the status bar to indicate a successful connection. Apps are unable to access the Internet.
- It stays on the loading screen indefinitely and never connects.
- It connects, but a blank login page appears with no content displayed.
- It connects without displaying a login page (Wi-Fi icon appears in the status bar), attempting to access anything in Safari will redirect to a blank login page with no content displayed.
- It connects without displaying a login page (Wi-Fi icon appears in the status bar), attempting to access anything in Safari will redirect to a correct login page however login credentials cannot be entered. Tapping on the username or password fields will bring up the keyboard, but entered text does not appear in the fields.
- It connects, successfully displaying the login page. Entering the correct login details will show that the login is successful, however the Wi-Fi icon never appears in the status bar. The Cancel button at the top-right never changes to "Done", and the login page cannot be dismissed. Closing the login page by either pressing the Cancel or Home Button will cause iPhone to disconnect from the network.

All of the tested networks have previously worked at some point on this same iPhone, and all of them suddenly stopped working at the same time. I haven't changed any settings or used any proxies or VPN services. Rebooting, resetting the network settings, or restoring iOS and setting up as a new device does not fix these issues. Originally I thought it was just a software issue, but given how everything stopped working at the same time and resetting does not fix the issues seems to suggest that a hardware fault may be the cause.
 
Last edited:

whetrick1

Well-known member
Oct 20, 2014
167
0
0
Visit site
Have you tried holding down the home and sleep button until the apple logo appears and letting them go and let the phone restart and see if it works then.