iPhone 5S won't connect to iMac, except for charging (no data cable problem)

SallieIT

New member
Jun 23, 2018
2
0
0
Visit site
Hello everybody,
My name is Sara, I am writing from Italy and I am new in the forum!
I read another thread (https://forums.imore.com/ask-question/286326-i-iphone-will-charge-my-computer-but-wont-connect-2.html#post3070913) for the very same issue (but with PC) in this forum, followed the applicable (to Mac) steps but didn't solve, so I decided to subscribe and ask for your help :)

Here some info:
- Both my iPhone and iMac run the latest versions of their OSs (iOS 11.4 and MacOS 10.13.5)
- My iPad Air2 connects no problem with the same data cable
- Tried with 3 different cables, one of them is Apple original iPhone cable and the other 2 are MFi
- If I put my iPhone in DFU mode, iTunes detects it and asks me to restore it in order to connect to it: I think HW problem is out of the game
- If I go to USB System Report>USB of my Mac, my iPhone doesn't show up (while my iPad does), nor does any error
And of course I also:
- restarted Mac and iPhone
- hard reset my iPhone
- checked for available updates (none)
- Deleted content of Lockdown folder (/private/var/db/lockdown/)
I am afraid there is something wrong SW-wise on my iPhone, but don't have a clue on how to detect and solve it... What do you guys think? Any hints?
Thank you very much for your help!
Greetings from Italy,
Sara
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,901
675
113
Visit site
If the cables are certified by Apple and still won't work, there may be a problem with either the charging port on the iPhone or the USB port on your iMac, but I can't say for certain. With that being said, I recommend you take one or both to the nearest Apple Store to have them diagnose the problem for you.
 

SallieIT

New member
Jun 23, 2018
2
0
0
Visit site
Hi,
Thank you for replying :)
Unfortunately the nearest Apple store i 300km away from me...
The USB port(s) on my iMac are working properly, as I can connect my iPad without any problem.
I also think there is no issue with the charging port of my iPhone, since it is detected when I plug it in in DFU mode.
I also tried to connect to a Windows PC I had never connect my iPhone to and still it won't show up in iTunes nor in the Device Manager.
I think there is something wrong SW-wise on my iPhone, i.e. the message for authorizing the computer to connect is not showing up for some reason and therefore the computer is unable to read the device. That said, I had no idea on how to solve it, except restoring to factory settings, which I will do if there is no other option, since I last backed up my iPhone 1 month ago...
Thanks again to anyone willing to help!
Saluti,
Sara
 

Trending Posts

Members online

Forum statistics

Threads
260,853
Messages
1,768,505
Members
441,270
Latest member
Artiefischel99