iPhone 5 Jailbreak - Problem Video and Sound


New member
Jun 28, 2013
Visit site
I'm on iPhone 5 iOS 6.1- evasi0n jailbreak.

My iPhone is having issues. I was in an app emulator PPSSPP attempting to download the Atrac3+ plugin. Phone rebooted- or respringed. After that, most Cydia apps didn't work. The phone outputted no sound, whether from speaker, in calls, out. People could not even hear me on the other ends of calls. No ringer sound, although vibration worked and works. Video did not play, even in the photos app. I did see a video play in the Cydia ads when looking for a package with no sound to it. All the tweaks disappeared in settings app. I saw in iFile that many files in ~/mobile/Documents that I had where missing. My iPhone was close to full. Some games crashed on opening. Wifi works fine. Cydia is there and works fine. When I re-installed the tweaks & dependencies via Cydia, they worked fine. For certain tweaks to work correctly, and not malfunction, I had to make sure the dependencies where installed, such as PreferenceLoader.

The problem that is still here now is that there is no sound, no videoplayback from any app- I think which uses iPhone video player. No sound in call from ear piece or speakerphone. A person does not hear on other end of my call.

An intriguing thing:
Airplay icon is there (I am not connected to anything, nor wifi), and it has no options for it. See Attached photos. This is where I think the problem could be and could be close to resolved, though I am not sure.

Ruled out hardware issues, considering when this happened.
I can access root from iFile just fine. I am not able to access root from iFunBox. I can only reach /var/mobile/Media/, though it says it jailbroken or "(Jailed)"- where it shows the name of the phone.
I am able to open Cydia, install apps from Cydia.
I can respring and reboot.

I have made this detailed, so we can save time and make it easier for you all to help.

Things I have tried:

Using the evasi0n tool. Gives error "error hmm... restore failed (-1)."
Tried on different computers.
Restore from an iTunes backup I previously had no problems with- before errors. This is to see if it may repair a messed up setting. iTunes returns error: "Could not restore the iPhone because an error occurred."
Also tried on different computers.
iLEX RAT- I successfully cleared all cydia apps with option 12, still no video, sound, etc.
Deleting "com.apple.iapd.plist" and reboot. Also tried deleting the other files similar to iapd, associated with accessories.
Tried plugging headphones in and out a couple of times- no change or recognition, as if I didn't plug it in at all. No "headphones" in volume display when plugged in.
Safe Mode- still no video, sound etc.
Deleting all Cydia Tweaks & Apps -via iLEX RAT
Alot of things from iphonenosound.com
Reboot and Hold Up to turn off all mobile substrate apps. - still no video, sound, etc.
In these attempts, the issues remained.

Even if I said forget the jailbreak, It's possible a restore will not even work, considering, I've seen people restore and still have sound problems. I'd like to isolate the problem, rather than me get to iOS 6.1.4 or iOS 7 beta and find I have the same issue. I would have wasted time and a jailbreak. That I think it may not work, and of course do not want to lose my jailbreak. The phone is fine generally, I just like to find a way to at least restore all sound and video until next jailbreak.

Many Tweaks I had installed:

SbRotator 6- springboard portion disabled- since I saw issues with it.
Color Keyboard
Folder Enhancer
Springtomize 2
Mobile Terminal

A few more small tweaks.
The phone still ran fluently- no lag though safe mode would appear, now and again.

Details in things that currently occur:
Voice Memos says when trying record, "No Microphone Available Connect a microphone to record voice memos."
No Music plays from music app, Videos do not play.
No Sound in call.
Speaker phone will not turn on. I press it, it shows its selected, then immediately unselects it.
There is no output from the sound whatsoever. Even in the ringtones app.
Of course, I checked the vibrate switch. Which is fine and set to off.
All videos, whether in photos app, YouTube app, YouTube from browser gives an error. Error from photos app "This operation could not be completed." Error on some YouTube videos "Playback error."
The phone recognizes no difference when headphones are plugged in.
Bluetooth does not turn on at all. It just shows the spinning wheel when attempting to toggle on and is seen on the "Off" position later.
Airplay icon is there. Shows as if I have something connected to it. I have never used it, accept and has no devices listed:
I would appreciate help to get this resolved.

Thank you.



Well-known member
Sep 13, 2012
Visit site
Sounds like you managed to corrupt/delete the software that controls AV.

People that have had sound problems persist through a fresh restore likely had hardware problems.


New member
Jun 28, 2013
Visit site
Would I be able to replace those files manually?

I am determined to keep my jailbreak! I think I may have found something looking at these reports:

Crash Logs from iPhone directly (As of today):

http://pastebin.com/5spPhLQL- Crash log - mediaserverd
Crash report Syslog- mediaserverd - Pastebin.com - syslog - mediaserverd

Crash Log from iTunes (~AppData\Roaming\Apple Computer\Logs\CrashReporter\MobileDevice\............):
(As of a few days ago)
Crash Reporter - Pastebin.com

imagent also on crash reporter-
Crash report- imagent- - Pastebin.com

I could post full syslog if needed

I seem to be having a problem with mediaserverd- either directly or indirectly.

Anybody postulate anything?

Also, I am not sure if there is a left over tweak causing the problem (doubt it) that was left uninstalled. Apparently I won't be able to uninstall it if Cydia does not recognize it as a package (without re-installing and uninstalling it I assume). For example, I have RecordMyScreen on home screen and can open and use it- yet it is not installed in Cydia. Same with BytaFont. I am thinking there could be a possibility that there is another tweak such as those, still there (but not there) causing problems... Just another idea.

Latest posts

Trending Posts

Members online

Forum statistics

Latest member