iphone 4 ios 4.2.8 jailbroken problems

saltyreefguy

Member
Jan 4, 2013
15
0
0
Visit site
I have jailbroke my i4 last year, its been running great. about 8 months ago, cydia disappeared, gettting api unavailble errors.
can still download some apps, but a good plenty of them get errors. The cdma i4@ ios 4.2.8 at bb 1.0.06 I saved my shsh blob,
somewhere but before i upgrade, i wanted to make sure what are my best options like upgrade ios and rejailbreak or try to solve
the api problems if possible to keep ios 4.2.8 or move on. Any good pointers from the gurus here? also, i have been getting those
silly java errors when i try to start tinyumbrella so i can save my shsh blob. thanks in advance...


anthony
 

rdiddy_25

Well-known member
Sep 20, 2009
3,419
9
0
Visit site
API errors from Cydia?? Never seen those. I think ur confusing Cydia and a certain app that just recently shut down its servers.
 

3cit

Well-known member
Nov 6, 2011
3,044
63
0
Visit site
Yeah you just need to clean your sources in cydia. However you most certainly need to join all of us here at 5.1.1.
There's no reason to stay on ios4
 

saltyreefguy

Member
Jan 4, 2013
15
0
0
Visit site
thats exactly what was on my mind, it was to ditch the ios4 and go on to 5.1.1 One problem though, i would sure like to re-save my shsh blob.
All day today i was trying to get tinyumbrella to work without any java jre errors. any of guys resolved any jre errors? thanks
 
Last edited:

Laelipoo

Well-known member
Aug 11, 2010
2,206
66
0
Visit site
You can also use redsn0w to save your shsh locally. Extras->shsh->remote (to pull from Cydia) new (to pull from an ipsw on your computer or local (to pull from phone).


iPhone 5 ✲ iPad 3 WiFi ✲ Macbook Pro running Lion 10.8.2 ✲ Xbox 360 ✲ Nintendo 3DS ✲ PS3

Beamed from a galaxy far, far away using Tapatalk!
 

1982ollie

Well-known member
Aug 25, 2011
711
33
0
Visit site
Yeah use redsn0w buddy. I've only ever got TinyUmbrella to work on 1 computer out of about 5 or 6. All with different errors, shame coz its the nuts when it works.
 

saltyreefguy

Member
Jan 4, 2013
15
0
0
Visit site
w0w, didn't know that redsn0w can save blob too, im going bonkers trying to get tinyt to run without errors...
I'm definitly going to use redsn0w to do this... thanks
 
Last edited:

3cit

Well-known member
Nov 6, 2011
3,044
63
0
Visit site
w0w, didn't know that redsn0w can save blob too, im going bonkers trying to get tinyt to run without errors...
I'm definitly going to use redsn0w to do this... thanks

Your issue with tiny umbrella is specific to your pc. Have you updated your adobe products lately?
 

saltyreefguy

Member
Jan 4, 2013
15
0
0
Visit site
Laelipoo, I'm want to save shsh blob before i upgrade 5.1.1 and jb.

1. open redsn0w
2. extras
3. shsh blobs(fetch,verify or use shsh blobs)
4. ** no remote option
im stuck in tyring to save blob or am i doing it wrong?
 

3cit

Well-known member
Nov 6, 2011
3,044
63
0
Visit site
There Are other tools too.
You can use Ifaith.
Also when you open cydia, at the top does it give you a list if your saved blobs?

And have you taken the next step in redsnow? Selected fetch?
 

saltyreefguy

Member
Jan 4, 2013
15
0
0
Visit site
I knew it felt to good too early... my next hurdle,

I used laelipoo's, instructions link to upgrade ios/5.1.1 all stages of restore went fine,entered dfu,
after limera1n stage, the restore menu >>extras>even more->restore menu pops up, all the info is
displayed(build, blobls local and remote is selectable.) ecid:xxxxx bottom message:iphone 4-vzw(pwned dfu mode)
it just sits there, the next button is not highlighted or back or quit.. what gives??? phone is still in dfu mode..

could my downloaded ios 5.1.1 possibly be corrupted? (the downloaded ios 5.1.1 was renamed as .ipsw instead of the .zip)
 

3cit

Well-known member
Nov 6, 2011
3,044
63
0
Visit site
You did the part where you stitched the blobs together?
And then you selected that new stitched blob?
The download should've come as an ispw, looks like a little whit box with some music symbol on it. Simple name...
Then you use redsnow to stitch your recently saved blobs. So you end up with another ipsw, this time the name isn't do simple... But same look.
Then you connect your phone to redsnow, get to restore,
If I remember correctly you select the firmware first (?) then redsnow guides you through dfu mode...
Your last post seemed a little out of order
 

saltyreefguy

Member
Jan 4, 2013
15
0
0
Visit site
i didn't do any type of stitching, hence probably why i got the problems.

I don't have the original blob prior to ios4 jb.(current status) if i save the blob off the current jb ios4, could
that be used?

thanks.
 
Last edited:

3cit

Well-known member
Nov 6, 2011
3,044
63
0
Visit site
So take the fresh stock apple 5.1.1 firmware.
Use redsnow and select the shsh blobs for 5.1.1 from your device.
Let redsnow stitch those blobs together for a custom 5.1.1 stitched firmware.
Tell redsnow to restore using the newly created 5.1.1 stitched firmware
 

saltyreefguy

Member
Jan 4, 2013
15
0
0
Visit site
I saved the blobs with success..

I try to stitch blob from remote, popup msg. ' no iphone 3,3 5.1.1 9b206 blobs for ecid *** were found
on apple or cydia servers. is my 5.1.1ipsw file corrupt? so im dowloading another now..

any suggestions?
 
Last edited:

3cit

Well-known member
Nov 6, 2011
3,044
63
0
Visit site
Try telling redsnow to look locally for your blobs that you successfully downloaded and saved
 

saltyreefguy

Member
Jan 4, 2013
15
0
0
Visit site
it seems that there was a file saved locally named .shsh inside are two files
1. .cache ( 1 file named lib-win.jar 1.51mb) its jar file
2. .known_devices (empty)

after many times fetching blob from my device and get a success window(nothing to do) but when i try to stitch
and look locally, no blob found...

any other suggestions..

** I am using redsn0w 0.9.win_15b3 to upgrade to ios 5.1.1, correct? just checking..
 

3cit

Well-known member
Nov 6, 2011
3,044
63
0
Visit site
If you're using redsn0w to restore, you don't stitch blobs at all. All you need is the stock copy of 5.1.1 and the sure fact that your blobs are on Cydia (Extras->SHSH->Verify).

Here's the tutorial (assuming you run windows): iClarified - iPhone - How to Upgrade Your iPhone 4, 3GS Without Updating the Baseband (Windows)

You can either tell it to upgrade the baseband or not. Doesn't matter.

i see that dev team says that. i was very unlucky when i tried restoring with redsnow... however i belive i was using redsno 15, not 15b2 or 15b3....
i was thinking that if he had problems using the simple way that maybe he could use stitched files.
im really confused though as to whats going on op....
you on windows or a mac?
xp? vista or 7?
what zip program are you using? winzip? 7rar? etc?
does the ipsw you downloaded look like this? ipsw.PNG
where did you save it to on your computer? save it somewhere its relly easy to find and point to (desktop)
 

Trending Posts

Members online

Forum statistics

Threads
259,606
Messages
1,763,729
Members
441,186
Latest member
EldenRasco