iPad 2 5.1.1 stuck at apple logo after cydia update/removal


New member
Oct 6, 2012
Visit site
Alright, so I've been in some tight spaces and have been able to fix my iDevices before, however this time I am stumped as my iPad 2 (iOS 5.1.1) gets to the apple logo and stays there. Any help would be greatly appreciated.

I went into Cydia on my iPad and removed a couple old tweaks that I don't use anymore, as well as updated 7-9 that had updates available for them. I for the life of me can't remember which ones I removed and which ones I updated. I don't know if it was the removal or the udpates that caused my phone to freeze. However I believe it was the removal of some tweaks because I did the updates first, resprung and it worked fine. Then did the removal, resprung, and it froze as it was respringing so I had to hold the power and home button down for about 7-10 to reboot. Now I can't get past the apple logo.

I've been searching the web trying to find a way to fix my iPad 2 without restore (since restoring would now force me to iOS 6 with no jailbreak).

What I've tried so far:
- SSH into iPad 2 (which works) and trying to restart spring board:
*iPad:~ root# killall SpringBoard
No matching processes were found
*iPad:~ root# killall -SEGV SpringBoard
No matching processes were found
*iPad:~ root# killall HUP SpringBoard
No matching processes were found (case sensitive) etc.... not working. It says that it cannot find the process which makes me think it's not even getting that far in the boot sequence.
- I've tried using the "reboot" and "halt" command through ssh to shutdown and reboot, still did not work. (it rebooted, but still freezes at apple logo)
- Tried booting tethered with RedSn0w but RedSn0w does not support the iPad 2 for tethered boot :( .
- Tried going into DFU mode then leaving DFU mode.
- Used ssh to remove files from Libray>MobileSubtratre>DynamicLibraries (wasn't exactly sure what I was doing on this one, just trying to follow somebody else's advice)

Now something that I did try was using the Launch command through SSH to launch SpringBoard and got this:
-iPad:~ root# launch SpringBoard
2012-10-06 01:51:33.356 launch[127:707] *** Assertion failure in -[UIApplication init], /SourceCache/UIKit/UIKit-1914.85/UIApplication.m:544
2012-10-06 01:51:33.363 launch[127:707] *** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'There can only be one UIApplication instance.'
*** First throw call stack:
(0x3197788f 0x317c2259 0x31977789 0x373fe3a3 0x31bd363b 0x1d90 0x1bec 0x1a88)
terminate called throwing an exceptionAbort trap: 6

No clue what that means. So as I said above, any help or guidance would be awesome as I really don't have a need for an iPad that isn't jailbroken. Thanks in advance for any help you may be able to give.

Trending Posts

Members online

Forum statistics

Latest member
Switch TV ON