iMessage won't send from my phone number only my email

Dean211284

Well-known member
Mar 2, 2011
138
0
0
Visit site
My wife used to receive regular SMS and Imessage both from my normal mobile number.
Yesterday I had to turn iMessage off to send her an SMS as I had no Internet signal. Now when I send her a imessage it says on her phone I'm sending it from my email address. I've went into settings and tried to remove my email address and use just the phone number but that option is "greyed out" meaning I have to use my email. Why is this? How can I make it send my SMS and iMessage from my phone number?
Thanks guys.
 

Dean211284

Well-known member
Mar 2, 2011
138
0
0
Visit site
Thank you for that link. A good read. However it does not help me here. I still don't know how to send iMessage from my phone number not my email as in settings the option to send from my phone number is 'greyed out' I can only choose my email or another email which I use my sons iPad do he can FaceTime me.
 

John Yester

Moderator Team Leader
Ambassador
May 23, 2012
8,847
1
0
Visit site
Your number will be defaulted to use the number to be reached at.. As well as any other email address you add. Example I have 4 addresses to use for mine, including my number.



Further down. choose start new conversations from (Your number)

I also have send as SMS selected, which it will default to in bad data areas...
 

Alli

Well-known member
Apr 28, 2009
10,927
370
0
Visit site
Are you using your iPhone or an iPad to do this? Do you have the same iCloud account on multiple devices?
 

Dean211284

Well-known member
Mar 2, 2011
138
0
0
Visit site
im using my iphone. and yes i am using the same icloud over my sons ipad, which uses his email, my wifes which uses her email but her imessages comes to me from her number, and my phone which only lets me use my email noy my number as its greyed out so i cant tick it.
 

Alli

Well-known member
Apr 28, 2009
10,927
370
0
Visit site
Yes. As Karen said, you don't want to share the same iCloud account or you won't be able to text or FaceTime each other anyway...since everything will originate from the same account. And then you will all get each other's iMessages and FT calls.
 

Dean211284

Well-known member
Mar 2, 2011
138
0
0
Visit site
Funnily enough we can still all FaceTime each other while using the same iCloud account. We use the same I could account so all of our photos are shared between my phone, the wife's phone and my sons iPad.
So basically we are saying that we don't know why my phone number is greyed out? I've reset, I've restored, I've tried everything but I can only choose to send Imessage from my email not my phone number as its greyed out.
This is baffling. Lol.
 

Alli

Well-known member
Apr 28, 2009
10,927
370
0
Visit site
Considering this is on your phone, there seems to be something else going on there. You might want to schedule an appointment at your local genius bar.
 

ridiculocity

Well-known member
Jan 13, 2011
276
2
0
Visit site
It sounds like because you all share the same icloud account you can only have one number associated with it. Since you turned yours off your wife's has defaulted as the main number.

It's a shame you all don't have your own cloud account because you can now share your photo stream across other users.
 

Dean211284

Well-known member
Mar 2, 2011
138
0
0
Visit site
So can i set up an icloud account just for my wife and i use my current one and it wont effect us bothj being able to use the same apple account to download apps? thanks guys
 

Wendi Brandao

New member
May 22, 2013
1
0
0
Visit site
I have had this same problem the last 2 days. The number is grayed out, but you can click on the email that you have set up in send and receive. After you do that click on delete email. You might have to wait a minute or so, but it will automatically revert back to your phone number. Also, you can just turn off iMessage. I found that taking out the email works better though. And it has nothing to do with iCloud being used by multiple people. I don't share it with anyone. The other person on the cell phone account is not having any issues either. Good luck!
 

mz_emz

New member
Jun 16, 2013
1
0
0
Visit site
I just had the same problem and fixed it!

Go into settings > messages > receive at > then sign out of your apple ID.

That fixed it for me :)
 

lounico239

New member
Aug 29, 2013
1
0
0
Visit site
same here? it just went away and I don't what to do? I've tried re-entering my phone number manually, I've tried deleting emails from imessage....still nothing. I'm at a lost
 

Linda Meers

New member
Dec 4, 2013
1
0
0
Visit site
I was having the same problem, and just figured it out. Sign out of iMessage. Sign back in, when it lists your phone number and email address (you'll see the check mark on your email address) tap your email address to uncheck it. Problem solved! It now will send messages from your phone number!
 

Trending Posts

Members online

Forum statistics

Threads
259,688
Messages
1,764,079
Members
441,188
Latest member
Ddearman0113