iMessage sync between devices

RevJar

Well-known member
Jan 12, 2011
68
0
0
Visit site
Running iOS 6 and iMessage syncing between iPad and iPhone are sporadic at best. What I send on one doesn't even show up on the other, even after I send a message from the second device. Turned off iMessage and back on again; have all registered phone number and email addresses set. Any ideas how to fix this or is it a bug?
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,624
616
113
Visit site
Running iOS 6 and iMessage syncing between iPad and iPhone are sporadic at best.
It's not perfect, but it works for the most part.
What I send on one doesn't even show up on the other, even after I send a message from the second device. Turned off iMessage and back on again; have all registered phone number and email addresses set. Any ideas how to fix this or is it a bug?
When you go toSettings/Messages/Send & Receive, is the "Start new conversations from" the same on both devices?
 

RevJar

Well-known member
Jan 12, 2011
68
0
0
Visit site
The start new convos are checked on both for the same account. Some messages are coming across one device while others aren't showing up still.
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,624
616
113
Visit site
The start new convos are checked on both for the same account. Some messages are coming across one device while others aren't showing up still.

Try restarting both devices and when they've both connected to the Internet, have a friend send you an iMessage.
 

dhaakenson

New member
Sep 22, 2012
1
0
0
Visit site
possible solution

I'm on iOS6 on iPhone and 10.8.1 on iMac. Messages were not syncing properly. At least for me, my problem was immediately solved by going to https://appleid.apple.com/cgi-bin/WebObjects/MyAppleId.woa/ and adding my iPhone number to my Apple account. Did the same for all the accounts in the family. Now, Messages syncs perfectly, and allows me to keep 'Start new conversations from' on the iPhone as my iPhone number, rather than setting it to match the email address used on my iMac.