iMessage Activation Issue

Barratrous Brighton

New member
Nov 12, 2012
1
0
0
Visit site
Hi, I am having trouble activating Imessage on iPhone 5 IOS6. It is constantly saying waiting for activation. I have ensured that my apple ID and password are correct. I have switched iMessage on and off several times, as well as my phone and all of my other devices are coming up with my iphone is now using my email address. I also ensure that I am connected to WIFI.
Has anyone had this issue and can help me fix mine.
 

johnanondoe

New member
Nov 7, 2012
2
0
0
Visit site
I had a similar issue are tried everything I could find online to fix it. At the end, I realized that my carrier had put a block on "spam" text messages. When you turn iMessages on it basically sends an invisible text message to Apple to verify it. With the block, the text message wasn't sent.

That probably just confused you more than helping you. Just call your carrier and ask them if there is some kind of spam SMS block. If there is, have them remove it and you'll be good.
 

eb_therebel

Well-known member
Sep 17, 2012
162
5
0
Visit site
Hi, I am having trouble activating Imessage on iPhone 5 IOS6. It is constantly saying waiting for activation. I have ensured that my apple ID and password are correct. I have switched iMessage on and off several times, as well as my phone and all of my other devices are coming up with my iphone is now using my email address. I also ensure that I am connected to WIFI.
Has anyone had this issue and can help me fix mine.

Try toggling airplane mode on for 5 seconds and turning it back off. This happened to me when I first got my i5 but that fixed it for me
 

Yptcn

Active member
Dec 5, 2011
28
0
1
Visit site
This might help.

Make sure that Time & Date ( In Settings-General ) are on automatic.

In Settings-Privacy-Locations-System Service ( All the way down ),make sure Define Time Zone is on.

It worked for me after pulling out a lot of hair ;-)))
 

timbervision

New member
Dec 29, 2015
1
0
0
Visit site
The tip given above worked immediately after so much frustration. Simply go to Settings, then General, then Date and Time, and then select "Set Automatically."
 

Trending Posts

Members online

Forum statistics

Threads
261,143
Messages
1,769,812
Members
441,294
Latest member
brunnic