I need to know if i can update my power Mac g4 to work with my iPad 2?

I

iMore Question

need to know if i can update my power mac g4 to work with my ipad 2.

i have a power mac g4 running osx 9 or so, not sure about it right now. i tried updating it about 2 years ago to work with my new ipad 2, so i could download my pictures and videos from it and store them on the mac. i tried updating the mac myself, but kept running into troubles getting updates to install. i know this mac is old, but i don't want to give up on it. please any advice would be greatly appreciated.
 

Rob Phillips

iPhone X & Apple TV Champion, Moderator
Champion
May 1, 2012
13,759
0
0
Visit site
Re: need to know if i can update my power mac g4 to work with my ipad 2.

Welcome to iMore! Three questions:

1. What version of OS X are you using? You can find out by clicking the Apple logo in the upper left corner of your screen and then selecting About This Mac.

2. What version of iTunes are you using? To find out, open iTunes, click on iTunes on the menu bar, and select About iTunes.

3. What version of iOS are you using?

I'm asking these questions because I'm wondering if there is incompatibility with the versions of software you're using given your older device. For example, iOS 9 is only officially supported on iTunes 12.3, which requires Mac OS X 10.8.5 or later.
 

MRMETALLICA

New member
Nov 4, 2015
2
0
0
Visit site
Re: need to know if i can update my power mac g4 to work with my ipad 2.

I have osx 10.4.11 installed, my itunes version is 9.02. i want to be able to use my ipad 2 to backup photos and videos on my g4, but every time i connect it to the mac, it never recognizes it. please help me.
 

Not Quite Right

Trusted Member
May 11, 2013
1,636
5
38
Visit site
Re: need to know if i can update my power mac g4 to work with my ipad 2.

I have osx 10.4.11 installed, my itunes version is 9.02. i want to be able to use my ipad 2 to backup photos and videos on my g4, but every time i connect it to the mac, it never recognizes it. please help me.

Not gonna happen ...

Mac System Requirements
Hardware:
Mac computer with an Intel processor
To play 720p HD video, an iTunes LP, or iTunes Extras, a 2.0GHz Intel Core 2 Duo or faster processor is required
To play 1080p HD video, a 2.4GHz Intel Core 2 Duo or faster processor and 2GB of RAM is required
Screen resolution of 1024x768 or greater; 1280x800 or greater is required to play an iTunes LP or iTunes Extras
Broadband Internet connection to use Apple Music, the iTunes Store, and iTunes Extras
Apple combo drive or SuperDrive to create audio, MP3, or back-up CDs; some non-Apple CD-RW recorders may also work. Songs from the Apple Music catalog cannot be burned to a CD.
Software:
OS X version 10.8.5 or later, Apple Music requires OS X version 10.9.5 or later
400MB of available disk space
Apple Music, Apple Music Radio, iTunes in the Cloud, and iTunes Match availability may vary by country
iTunes Extras require OS X version 10.10.3 or later