How can I get Siri to send SMS not iMessages when a friend has a non-iPhone?

bobbob1016

Well-known member
Dec 4, 2010
214
0
0
Visit site
I've tried having Siri text different numbers that only have a phone number as mobile not iPhone, but Siri still sends them as iMessages. Is this by a "feature" to get me to bug my friends into getting iOS devices, or am I missing something?
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,643
618
113
Visit site
If the people you are texting are using i-devices and have iMessage enabled on those device then yes, those messages will indeed be sent as iMessages. However, if the people you are texting DO NOT HAVE i-devices or DO NOT HAVE iMessage enabled then those messages will be sent as SMS messages. Just know that if the messages are BLUE then they are iMessages. If they are GREEN, they are not iMessages.
 

bobbob1016

Well-known member
Dec 4, 2010
214
0
0
Visit site
I know that, what I mean is Siri sends as an iMessage to my non-iPhone friends. Checking "Contacts", they're there as mobile, not iPhone. But Siri still sends as iMessage, then I get the exclamation mark notification on Messages.
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,643
618
113
Visit site
I know that, what I mean is Siri sends as an iMessage to my non-iPhone friends. Checking "Contacts", they're there as mobile, not iPhone. But Siri still sends as iMessage, then I get the exclamation mark notification on Messages.
I don't know what to tell you. After reading your latest reply, I grabbed my iPhone 4S, and used SIRI to send my oldest son who has an Android device a text message stating, "Good morning", and it worked without a hitch. I'm sure you have already, but go to Settings-Messages and then scroll down and verify that "Send as SMS' is turned ON. Do the same for "MMS Messaging", if applicable. Also, try signing out and then signing back in to iMessage.
 
Last edited:

bobbob1016

Well-known member
Dec 4, 2010
214
0
0
Visit site
I don't know what to tell you. After reading your latest reply, I grabbed my iPhone 4S, and used SIRI to send my oldest son who has an Android device a text message stating, "Good morning", and it worked without a hitch. I'm sure you have already, but go to Settings-Messages and then scroll down and verify that "Send as SMS' is turned ON. Do the same for "MMS Messaging", if applicable. Also, try signing out and then signing back in to iMessage.

Didn't mean to come off badly. I feel stupid, forgot to turn send as SMS back on after going to iOS 6.1.2 (did setup as new).
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,643
618
113
Visit site
Didn't mean to come off badly. I feel stupid, forgot to turn send as SMS back on after going to iOS 6.1.2 (did setup as new).

Aw don't worry about it, my friend. It happens...:)...I'm just glad you figured it out. Anyway, take care and enjoy the rest of your evening. :D
 

Highrisedrifter

Well-known member
Sep 19, 2012
2,999
0
0
Visit site
Also Messages regardless of whether Siri sends them or you do it manually doesn't care what you have the contact's phone number tagged as in your Address Book. Apple maintains some sort if database to tell Messages whether to use an iMessage or SMS.

Like any data it can sometimes be wrong especially if someone used to have an iOS device and switched their phone number to Android without turning iMessages off.

Just what i was about to say. I had exactly this issue with my good lady wife. The number used to be on an iPhone 4 but hers got completely smashed so she now uses my old Galaxy S2 and this issue persisted for a while before inexplicably stopping one day for no appreciable reason.
 

Trending Posts

Members online

Forum statistics

Threads
259,666
Messages
1,763,996
Members
441,188
Latest member
Remona94B9