How can I fix it when I can't redownload previously installed apps on my 4S?


iMore Question

I'm gonna put it plainly, my phone is pretty terrible.
It's an 8GB iPhone 4S. I got it cheap through my provider (Verizon) and I currently can't afford a new one so I'm just trying to live with this one until I can.

But it's been having nonstop problems since I made the mistake of installing iOS9 a couple months back, including but not limited to:

? Constant freezing in safari
? Apps crashing constantly
? Going from up to %22 battery life to dead in an instant.
? Not getting notifications sometimes, and rarely not even getting calls, just goes straight from idle to "missed call/voicemail" notifications.
? And More!

Most of these I can put up with. I know the hardware is outdated. But a recent issue has been more than frustrating.


Recently I had used all my storage, and had to delete some stuff. Photos, apps, music, etc. I actually deleted all of my apps as every single one of them crashed upon opening and I assumed it was because of the 0 bytes of storage left.

So once I deleted all my stuff, and had some room on my phone, I tried to redownload a few of the apps...

And I can't. At all.

Apps that previously existed on this phone will NOT download. Others work just fine.

The apps I had before (like Facebook Messenger, Twitter, Instagram, Snapchat, and BB&T Mobile Banking) appear in the App Store with the iCloud button with the blue arrow, and when I click it, it simply doesn't work.
The cloud will blink for a moment as if it's going to download, but then it goes back to normal.
When I try pressing the cloud a few times, it will just get stuck on the downloading circle icon and not download the app still.
The only app I've been able to install successfully since this started happening is Facebook, which now works just fine as always.

Another forum I saw for this issue suggested that I reboot my phone, reset my network settings, sign in and out of iTunes, and/or disconnect/reconnect from my wifi network.

And naturally none of those things worked. I don't think this is a network issue, I think it's a hardware issue.

I would like to know if anybody might have some insight on what I could do here besides "buy a new phone."
I still plan to buy one of course, but I'm not sure if I'll be able to until the holidays, and I don't think I can put up with this thing for the next 6 months.

Thank you, rant over. Please help!


Feb 20, 2014
Visit site
Hi, welcome to iMore.

Seems like you have to reset the iPhone.

Go to Settings > General > Reset > Erase All Content and Settings. Put in your passcode and wait for the process to finish. After that, you can either put restore from a backup or set your device as new.
Once done, go to AppStore > Updates > Purchased and download all apps you want / need.

I hope this helps. If not, please join our forum and ask away.


Well-known member
Oct 29, 2013
Visit site
Sorry to hear this, it must be related to the 8g thing. Have you looked to see what storage your phone says you have after your ruthless deletions ?! My 64gb 4s seems fine at the moment, but will almost certainly go downhill with ios10 and apps are upgraded to it.


Oct 2, 2013
Visit site
For Facebook, try the client, Friendly+. Be sure you log in to Facebook in Settings. Twitter also has clients. Or just log in to them in Safari.

Latest posts

Trending Posts

Members online

Forum statistics

Latest member
tyguest 321