How can I downgrade my iPhone 3G (3.1.3 firmware) baseband from 06.15.00 to 05.13.04?

I

iMore Question

I have an iPhone 3G locked to AT&T, am trying to unlock it to move to T-Mobile. I followed the instructions on [Redacted], but ran into some problems.

My original firmware was 4.2.1 with baseband 5.15.04. I used Redsn0w 0.9.14b2 to install iPad baseband 06.15.00. After this I was unable to go any further, I kept getting various iTunes errors. So, I downgraded the firmware to 3.1.3 by connecting the phone to my laptop, running TinyUmbrella, ran TSS server, used iTunes to Shift+Restore the 3.1.3 firmware. At this point I had an iTunes error 1015. I then exited iTunes, used TinyUmbrella to Exit Recovery, disconnected from the laptop, inserted the T-Mob Sim, reconnected to the laptop, ran iTunes and the phone was activated and unlocked.

The phone works but data is very slow, even when connected to WiFi, so I figured I should downgrade the baseband to 05.13.04 to improve performance and get back GPS. The problem is when I use RedSn0w 0.9.14b2 to downgrade it says my IPSW (3.1.3) is incompatible. On the other hand, if I use an older version of RedSn0w (e.g. 0.9.2) it is compatible with the 3.1.3 IPSW but has no option to downgrade the baseband.

So, what route can I take? Should I upgrade my firmware back to 4.2.1 via iTunes? Will it let me do that (I don’t have any saved blobs etc), and even if it does will I run into other issues – iTunes errors or phone locked again? Is there some other way to downgrade the baseband?

Any help/advice is greatly appreciated. Thanks.

PS -- when I installed the 06.15.00 baseband I must not have checked "Install Cydia", since I don't have Cydia on the phone now, but it still is unlocked.
 
Last edited by a moderator:

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,749
638
113
Visit site
If this problem still exist, please be a bit more patient while awaiting a response from one or more of our knowledgeable members. Thanks...:)