Guide to troubleshooting common issues during the jailbreak process

Not open for further replies.

Allyson Kazmucha

Well-known member
Apr 5, 2009
Visit site
There's no question that jailbreaking adds tons of functionality to your device but we have to face it, along with more control and deeper access to the file system can come bugs and problems.

My jailbreak fails or the jailbreak tool crashes and quits. What do I do?

Before trying any of the steps below, make sure you have NO passcode on your device. This has been known to stall or crash a few different jailbreak utilities. You can, of course, re-enable it after jailbreaking. But while you perform the process, make sure your device is NOT passcode locked.

1. Check and make sure the tool you are attempting to use is supported under the platform and operating system you're using.

2. Unplug your device and plug it back in. If possible, try a different USB cable or port on your computer.

3. Make sure your iPhone, iPad, or iPod touch firmware is compatible with the tool you are trying to use.

4. Delete the jailbreak utility from your computer and re-install it fresh to rule out a corrupt install.

5. If possible, try jailbreaking your device from a different computer. If it works, the problem probably lies with your actual computer. As a side note, I'd make sure you're running as an administrator if you're running into computer issues. (Admin for windows, Sudo for Mac users)

6. Reset all the settings on your device. Go into Settings --> General --> Reset --> Reset all settings. This will NOT delete any data from your device but it will restore all default system settings.

7. If a different computer doesn't work, the problem probably has something to do with your device itself. Back up your device in iTunes or via iCloud. Wipe your device to factory and try the jailbreak process again. You can wipe your device by doing a clean restore via iTunes or going to Settings --> General --> Reset --> Erase all content and settings

The jailbreak seems to have worked but I can't get Cydia to install, I get a network error

1. This happens a lot if you are using a tool like Greenpois0n that requires you to launch their icon in order to obtain Cydia. Try going into Settings --> General --> Network --> and turn ON your VPN. (If VPN is asking you for a password, just continue with the field blank.) Your phone should give you an error and then reboot. When it comes back on, you "should" now have Cydia.

2. If your device does NOT give you an error and reboot after toggling it to ON or doesn't give you an error, try resetting your network settings under Settings --> General --> Reset --> Reset all Network Settings, then try toggling VPN on again.

3. If none of the above steps have worked, your best bet is a clean restore on your device after you've backed up all your data. Jailbreak clean and then restore your information.

My jailbreak has worked and I can get in Cydia but I'm getting errors or can't download anything

The following errors are common -

SERVER NAME: connection refused - that server is probably down. Nothing you need to do on your end. For example, I get this error from POSIX now and then.

I wasn't able to locate file for the libactivator package. this may mean you need to manually fix this package. - You'll notice if you get this error you can't install anything from Cydia. Literally, nothing. It's actually a very easy fix. Go into your device's Settings --> General --> Reset --> Reset network settings. This should fix any issue you have with libactivator erroring out.

These are common issues many new users may experience at first. These are by no means the only errors you may get. And hey, some of you may never see these. If you've found a different error while jailbreaking or getting set up with Cydia, let us know. If you found a way to fix it, let us know that too and we'll add it to the guide!
Not open for further replies.

Trending Posts

Members online

Forum statistics

Latest member