Exchange Gmail

thecondor33

Member
Dec 24, 2011
15
0
0
Visit site
I've been attempting to set up my Gmail on my iPhone as an Exchange acct as I'd like it to push rather than fetch every 15 min, etc. I continue to get an error "incorrect password" please enter your gmail password. I have searched the forums, and I notice the tip is to unlock Captcha. I've tried that several times with no luck. I've also tried turning on the 2 step verification process and getting the application specific password, to no avail. I cannot seem to find any other suggestions, and have searched all over the forums. Please let me know if there is something I'm missing.

Thanks!!
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,761
641
113
Visit site
I've been attempting to set up my Gmail on my iPhone as an Exchange acct as I'd like it to push rather than fetch every 15 min, etc. I continue to get an error "incorrect password" please enter your gmail password. I have searched the forums, and I notice the tip is to unlock Captcha. I've tried that several times with no luck. I've also tried turning on the 2 step verification process and getting the application specific password, to no avail. I cannot seem to find any other suggestions, and have searched all over the forums. Please let me know if there is something I'm missing.

Thanks!!

If you want "push" email from Gmail using the default mail app, it is easier to configure your Gmail using the Microsoft Exchange setup. If it prompts for a mail server, use m.google.com.
 

Attachments

  • ImageUploadedByiMore Forums1349135707.278614.jpg
    ImageUploadedByiMore Forums1349135707.278614.jpg
    81.9 KB · Views: 64

thecondor33

Member
Dec 24, 2011
15
0
0
Visit site
If you want "push" email from Gmail using the default mail app, it is easier to configure your Gmail using the Microsoft Exchange setup. If it prompts for a mail server, use m.google.com.

Not to be rude, but did you read through my entire post? That's exactly what I'm trying to do. That's where I'm running into the error.
 

LCW

Well-known member
Jul 3, 2010
1,468
8
38
Visit site
Where is says "email" do you have @gmail.com? If not, it should.

Domain should be blank.

Where is says "username", there should no @gmail.com.

SSL on, S/Mime off.

Should work if you have the right server.
 

thecondor33

Member
Dec 24, 2011
15
0
0
Visit site
Where is says "email" do you have @gmail.com? If not, it should.

Domain should be blank.

Where is says "username", there should no @gmail.com.

SSL on, S/Mime off.

Should work if you have the right server.


I am able to get it set up, but as soon as I open the mail app there is a pop up box that says Password Incorrect "Enter the password for the exchange account". I will then enter my gmail password and it does not work. This box keeps popping up. All the forums I've found on here say to enable captcha, but I've done that with no luck. It's driving me crazy.
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,761
641
113
Visit site
Not to be rude, but did you read through my entire post? That's exactly what I'm trying to do. That's where I'm running into the error.

I know you're not trying to be rude and I'm not taking it as such, especially when you're right. ;) I have a habit of quickly looking at a post instead of intently reading it. Sorry about that. Anyway, see the attached screenshot and set it up likewise using your information, of course. Use SSL should also be turned on. If you still get a password error, login online to make sure the password is working and then if so, reboot your iPhone and retry.
 

Attachments

  • ImageUploadedByiMore Forums1349139720.223477.jpg
    ImageUploadedByiMore Forums1349139720.223477.jpg
    117.9 KB · Views: 62

thecondor33

Member
Dec 24, 2011
15
0
0
Visit site
All of that info is correct, in fact I'm able to get it set up. The issue occurs when I then open my mail. That is when the error pops up asking for an exchange password.
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,761
641
113
Visit site
All of that info is correct, in fact I'm able to get it set up. The issue occurs when I then open my mail. That is when the error pops up asking for an exchange password.

That is definitely not normal. Try this: delete the account, reboot your iPhone and set up your gmail account via exchange again. It should not be asking for your password when you go to open your email.
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,761
641
113
Visit site
I don't. In fact, I even tried to enable it just so I could create the verification password. Then tried that password, no luck.

I found this on the web:
http://forums.macrumors.com/showthread.php?t=1162114

Hi all,
I solve my issue in the following way, after a whole day of struggling:
The Exchange password that your iPhone is asking is not your gmail account one. It's an additional password that you should generate from Google site in order to unlock their security checks. This check is required because you are trying to access Gmail not from gmail.com website but from a third-party app (in this case, Exchange on a iPhone).
Go here:
http://support.google.com/mail/bin/a...answer=1173270
and follow instructions to generate that password.
Once it is generated, write it down on paper, go on your iPhone mail settings>Exchange account, and whenever the popup appears asking for Incorrect Exchange password, insert the one written on paper.
It worked right away for me, hope this will help

Riccardo
---
iPhone 3G
iOS 4
...
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,761
641
113
Visit site
Unfortunately those steps are what you new to do to get an application specific password if you have 2 factor auth turned on. If you don't have it turned on, then you cannot generate that type of password.

I know, but something is causing his password issue and we cannot figure it out. It may just iron itself out in a few hours.
 

thecondor33

Member
Dec 24, 2011
15
0
0
Visit site
I've tried captcha probably about 15 times, no luck. Also tried turning on 2 step verification and generating a password. Used that password. Again, account was successfully created, but then this error box pops up. So incredibly frustrating. There are countless threads on the gmail help site with the same issue, but i cant seem to get any of the suggestions to solve it. Wish gmail could straighten this out.
 

Peligro911

Well-known member
Jun 1, 2011
5,878
136
0
Visit site
I've tried captcha probably about 15 times, no luck. Also tried turning on 2 step verification and generating a password. Used that password. Again, account was successfully created, but then this error box pops up. So incredibly frustrating. There are countless threads on the gmail help site with the same issue, but i cant seem to get any of the suggestions to solve it. Wish gmail could straighten this out.

That is really strange I have had my gmail on exchange since the iPhone 4 launch had your issue but the captcha disable fixed it ...

Does it do it if you try a diff gmail account ?

If it is just yours maybe log into gmail and reset every setting to default and then try re setting up the account on your phone
 

trmoney24

Well-known member
Jul 18, 2012
108
0
0
Visit site
another option is to use the Gmail app. If you want to get your contacts synced to your phone, you can use this method, which is what I prefer. When you sync you contacts with the exchange setup, most of my contacts, all the email addresses will change to "other" instead of remaining as home, work, etc. this has happened to almost everyone I have suggested to use the exchange setup.
so basically i use the gmail app to check emails and this setup below to sync my gmail contacts to my iPhone.
Sync contacts with your iOS device - Gmail Help

The password issue may happen with the contact setup so not sure if that will be a good enough work around. sorry i don't have any suggestions to actually fix the password issue.
 

thecondor33

Member
Dec 24, 2011
15
0
0
Visit site
I just wanted to give an update, I finally got this to work!! Ended up using my email address as the user name as well, and for some reason it just finally worked. Funny thing, I had tried this a few days ago to no avail. Hopefully I don't get that pop up when checking my email at all, but it seems to be good to go. Thanks everyone for the suggestions!
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,761
641
113
Visit site
I just wanted to give an update, I finally got this to work!! Ended up using my email address as the user name as well, and for some reason it just finally worked. Funny thing, I had tried this a few days ago to no avail. Hopefully I don't get that pop up when checking my email at all, but it seems to be good to go. Thanks everyone for the suggestions!

Thank you for updating us. Take care and enjoy your weekend...:)
 

TurboTiger

Well-known member
Nov 27, 2003
2,773
11
38
Visit site
I'm getting a MacBook Air soon.
I currently sync mail, calendar and contacts on my iPhone 4S and my iPad 2 to Gmail through Exchange.

When I set up Exchange on my new MacBook Air, am I to use m.google.com if prompted for a server?
I know to use that I use it as the server when setting up iPhone and iPad but not sure about the MBA.

TIA
 

Trending Posts

Members online

No members online now.

Forum statistics

Threads
260,284
Messages
1,766,202
Members
441,232
Latest member
Gokox