Disconnect nearby wifi not working

mws_1984

Well-known member
Mar 14, 2015
259
0
16
Visit site
How do I get it to stop connecting to nearby wifi? I go on the control center screen. I turn it off. It even says disconnecting nearby wifi until tomorrow. But it still will connect back up not long from when I turn it off.
 

doogald

Trusted Member
Oct 23, 2012
2,768
102
63
Visit site
How do I get it to stop connecting to nearby wifi? I go on the control center screen. I turn it off. It even says disconnecting nearby wifi until tomorrow. But it still will connect back up not long from when I turn it off.

Settings / WiFi, turn off the WiFi switch. (Or use Siri to turn off WiFi.) The control panel just disconnects from whichever WiFi access point you are connected to but leaves the WiFi radio on. I'm not sure why it would reconnect - maybe it's because you were close to another access point and then came back to your own, so it decided to connect you? It shouldn't work that way, though.
 

mws_1984

Well-known member
Mar 14, 2015
259
0
16
Visit site
Settings / WiFi, turn off the WiFi switch. (Or use Siri to turn off WiFi.) The control panel just disconnects from whichever WiFi access point you are connected to but leaves the WiFi radio on. I'm not sure why it would reconnect - maybe it's because you were close to another access point and then came back to your own, so it decided to connect you? It shouldn't work that way, though.

I do have wifi in car. So maybe that’s why. I only run my music off Bluetooth at times. But some phone apps like when I doordash get all screwed up when wifi is on. To point the network is messed up. And I Can’t get orders or map to show. I found having wifi turned off clears up the issue.
 

doogald

Trusted Member
Oct 23, 2012
2,768
102
63
Visit site
It must be that the algorithm is "remain disconnected until tomorrow (as long as you stay in the same place)".

I think in your case that you're best off turning the WiFi radio off completely in Settings / WiFi (or using Siri to do the same.) Note that you can get to Settings / WiFi from the control panel by long-pressing on the network control, which brings up a more detailed panel, then long-pressing on the WiFi icon and then choosing "WiFi Settings" from the popup that shows up.
 

Trending Posts

Members online

Forum statistics

Threads
260,677
Messages
1,767,801
Members
441,256
Latest member
emii28