Disable Auto Check E-Mails for Mail App when Starting Contacts App

ZeTaBYTeS

Well-known member
Jul 21, 2009
57
0
0
Visit site
I have upgraded both my iPhone 3G and 3GS to iOS4. Slow performance aside, I notice that whenever I start the Contacts app, the Mail app will auto-check for e-mails in the background (then displays red circle with no. of unread e-mails). I prefer to check for e-mails manually. At the moment, I have 2 e-mail accounts configured for both iPhone 3G and 3GS - Hotmail (POP3) and work mail (IMAP).

Yes, I have already done this under Settings > Mail, Contacts, Calendar:

- Fetch New Data > Push > Off
- Fetch New Data > Fetch > Manually
- Fetch New Data > Advanced > "mail account name" > Select Schedule > Manual

And yes, I have terminated all background apps and restarted both iPhone for many times already. Does anyone face this issue? Any solutions?
 
Last edited:

iNitvizn

Well-known member
Jun 18, 2010
65
0
0
Visit site
Yes - my 3G started doing the same thing after I upgraded it to iOS 4. I wasn't able to figure out how to stop it either.

I stopped trying when I got my iP4 - it doesn't happen with my 4.
 

ZeTaBYTeS

Well-known member
Jul 21, 2009
57
0
0
Visit site
Yes - my 3G started doing the same thing after I upgraded it to iOS 4. I wasn't able to figure out how to stop it either.

I stopped trying when I got my iP4 - it doesn't happen with my 4.

Thanks for sharing. iPhone 4 is yet to be available in my country :( If anyone has a solution to this or similar experience, do share.
 

ZeTaBYTeS

Well-known member
Jul 21, 2009
57
0
0
Visit site
I think I may have found a workaround on this by changing one of the setting above:

- Fetch New Data > Advanced > "mail account name" > Select Schedule > Fetch

Mail app has stopped auto-checking for e-mails whenever I use the Contacts app now :D
 
Last edited:

Latest posts

Trending Posts

Members online

Forum statistics

Threads
259,570
Messages
1,763,599
Members
441,182
Latest member
PedroWagner