Cydia Error... sub-process error code 2/essential updates...

mceyedol

Member
Jun 19, 2009
15
0
0
Visit site
Right so I managed to update to 3.0 and jailbreak it using redsnow.

I've loaded "Cydia" and it says there are some essential upgrades. I think okay lets upgrade....

upgrades are for "Cydia Installer" & "Debian Packager"

select upgrade on the installer and I get the following error in a little box:
- Sub-process /usr/bin/dpkg returned an error code (2)

The black screen with the dos style screen says:
dpkg: pasre error, in file '/var/lib/dpkg/status' near
line 26 package 'firmware'
duplicate value for user-defined field 'Name'

so I select okay. Try again and the same thing happens... can anyone help?

I'm not able to install any cydia/icy progs at all... :(

Any help would be great. Thanks Michael
 

MDT

New member
Jun 22, 2009
2
0
0
Visit site
I am wondering if you installed for Cydia and Icy
I was getting the same error you were, but later (after installing some things thru/for Icy) started getting"

"Couldn't configure pre-depend dpkg for ncurses, probably a depencency cycle."

I am going to try to re-run redsnOw without Icy
I'll repost with the result.
 

mceyedol

Member
Jun 19, 2009
15
0
0
Visit site
hi there,

yes i did install redsn0w with "icy".... wonder if it was icy causing the problem? interested to find the results of yr experiment. ;)

thanks, michael
 

MDT

New member
Jun 22, 2009
2
0
0
Visit site
It worked for me.
I got this idea from reading responses to other problems at another site.

I simply ran redsnOw again, but didn't check to add Icy.
when all was reloaded... Cydia works. and I still apear to have icy too.

Hope this helped you.
MDT

EDIT: yes!!! I have SBSettings back.
Thankyou to some user called MESS from the MACRUMORS forum
and to all the guys who made redsnow and sbsettings and to the DEVteam
 
Last edited:

help#IM

New member
Jun 22, 2009
1
0
0
Visit site
its true, i just jailbroke and added ICY before, but i kept gettin the same error, so i did the jailbreak again in redsn0w and didnt choose to include ICY and now everything is workin fine :)
 

chrstphr.ross

Well-known member
Jun 18, 2009
120
1
0
Visit site
I have an iPhone 3G on 3.0 running Cydia and Icy installers...i used the new Pwnage tool on my Mac though >.< never had a problem.
 

irha

New member
Jun 26, 2009
1
0
0
Visit site
installing only cydia did it

Just wanted to say thank you for the workaround. I also got cydia working by selecting only cydia while jailbreaking.
 

bluesteelz

Member
Jun 26, 2009
14
0
0
Visit site
can anyone help

i dont like this 3.0 very much at but its too late now,main problem for me is that my favorite two apps are not working right...one v wallpaper...and ... two..mobilefinder. witch is what i use to copy new videos from mix tube. and then i install them into vwallpaper as my ring tones... can some tell me what i can do to fix this or if theres a patch for these apps thanks...
 

Trending Posts

Members online

Forum statistics

Threads
260,718
Messages
1,768,001
Members
441,261
Latest member
dirtyvu