Connection to Kenwood Headunit - Bluetooth

camaroz1985

Trusted Member
Sep 2, 2016
805
0
16
Visit site
I have an SE, and my wife has a 6S. Neither will connect to the bluetooth in my truck. I have a Kenwood DNX691HD headunit, and it has always connected to every Windows Phone and Android Phone I have used, even my old iPhone 6, but it will not connect to the 6S or SE. I'm wondering if anyone has had any experience with this. I tried to search but didn't have much luck. This is with using Bluetooth, not CarPlay (the headunit doesn't have CarPlay, but if I can't get this working I might bite the bullet and get one that does).
 

camaroz1985

Trusted Member
Sep 2, 2016
805
0
16
Visit site
This could be moved to the CarPlay subforum.

I did buy a DNX693S which has CarPlay, so the issues I am having with the current headunit will be resolved shortly.
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,749
638
113
Visit site
This could be moved to the CarPlay subforum.

I did buy a DNX693S which has CarPlay, so the issues I am having with the current headunit will be resolved shortly.

Okay, great,and please continue to keep us informed of your progress. Take care...
 

camaroz1985

Trusted Member
Sep 2, 2016
805
0
16
Visit site
I messed around more with the existing unit, and did get bluetooth audio playback to work. Had to connect to bluetooth, so it shows up on both the headunit and phone. The phone still says it can't connect. Then go into source settings on the headunit, then ipod settings, and change the connection method to bluetooth.

Now I can play music, podcasts, etc., but answering phone calls, voice commands to siri, etc. are still through the phone. Hope to have the new headunit installed this weekend maybe, so this is hopefully only a temporary issue.