• Welcome to the all-new iMore Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

can't restore disabled iphone


iMore Question

I tried to restore my phone but itunes shows a message that it should be updated to ios 9.3.3 that I already have btw. Anyway I tried to update it but it shows an error of running time. I don't have backup at all.

Rob Phillips

iPhone X & Apple TV Champion, Moderator
May 1, 2012
Welcome to iMore! Are you trying to update over-the-air (using Settings > General > Software Update on your device) or through iTunes? Whichever way you're trying to update, try the other method. If that doesn't work you may need to boot into recovery mode and update using iTunes.


Oct 2, 2013
Thank you:)
i did, but it starts the update of ios that I already have. Download started but at the end pop up a message saying this is a timing error

Does it say this:
?Network Connection Timed Out?? If so,
Connect to Internet and use the
Latest version of iTunes.
Things to try:

Disable Firewall and Anti-Virus
Uninstall and Re-install iTunes
DFlush DNS Cache