Birthday Alert Issue

Wildo6882

Well-known member
Feb 27, 2011
1,228
9
0
Visit site
So I have birthdays from contacts in my calendar. I have the default notifications on birthdays set to "None" in the settings because I just want to see that someone has a birthday, not be full on alerted to it. Anyway, I can't get it to stop alerting me two days before the birthday at 9:00 am. Anyone know what to do here?
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,772
644
113
Visit site
On your device, go to Settings-Mail, Contacts, Calendars and then scroll sown to the Calendars section and select "Default Alert Times". Tap on "Birthdays" and make the necessary changes.
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,772
644
113
Visit site
That's the thing, the default time is already set to "None". So I shouldn't be getting these alerts.

You're right. You shouldn't be getting the alerts. Is it possible that Facebook or any other social network you may have is set to alert you in advance?
 

Wildo6882

Well-known member
Feb 27, 2011
1,228
9
0
Visit site
You're right. You shouldn't be getting the alerts. Is it possible that Facebook or any other social network you may have is set to alert you in advance?

Nope. Don't let Facebook sync contacts. I have no idea why it's doing it. I just got a replacement due to a blown speaker and had to use IMAP setting for Gmail now, but I removed contacts birthdays from the calendar and only use the iCloud ones.
 

tech_fan

Well-known member
Jan 7, 2013
218
0
0
Visit site
That's the thing, the default time is already set to "None". So I shouldn't be getting these alerts.


Try powering the phone off and then turn it back on again to see if that solves it. Whenever my phone acts quirky, powering it off and back on again fixes it.
 

Wildo6882

Well-known member
Feb 27, 2011
1,228
9
0
Visit site
So I think it's something to do with the Gmail issue. For some reason it has all my gmail contact birthdays even though it doesn't have my contacts synced (all contacts are through iCloud). So they're actually listed in there twice. Guess I'll probably have to remove my contact birthdays from my gmail calendar. I think that's actually the issue.
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,772
644
113
Visit site
So I think it's something to do with the Gmail issue. For some reason it has all my gmail contact birthdays even though it doesn't have my contacts synced (all contacts are through iCloud). So they're actually listed in there twice. Guess I'll probably have to remove my contact birthdays from my gmail calendar. I think that's actually the issue.

To fix your duplicate entries in your contacts, all you have to do is go to Settings-Mail, Contacts, Calendars-Gmail and then turn OFF contacts. Only the contacts from iCloud will be displayed in your contacts app. As for the birthdays, try setting the Google Calendar as your default calendar (Settings-Mail, Contacts, Calendars and then scroll down to the 'Calendars' section and select your Google calendar as the default). Hopefully, that will rectify the situation. Let us know what happens if you opt to try it out.
 

sting7k

Well-known member
Dec 15, 2008
3,011
62
0
Visit site
So I think it's something to do with the Gmail issue. For some reason it has all my gmail contact birthdays even though it doesn't have my contacts synced (all contacts are through iCloud). So they're actually listed in there twice. Guess I'll probably have to remove my contact birthdays from my gmail calendar. I think that's actually the issue.

I've found some other comments around the web about this issue. I also have it. It seems that iOS will still show birthday notifications from a calender even if the calender is not selected. For me I traced it to my outlook.com (which I believe got birthdays from Facebook when I converted from Hotmail) calender. Even though I do not have that calender selected to display I still get notifications in notification center.
 

Wildo6882

Well-known member
Feb 27, 2011
1,228
9
0
Visit site
I've found some other comments around the web about this issue. I also have it. It seems that iOS will still show birthday notifications from a calender even if the calender is not selected. For me I traced it to my outlook.com (which I believe got birthdays from Facebook when I converted from Hotmail) calender. Even though I do not have that calender selected to display I still get notifications in notification center.

Think if I convert my Google calendar to icloud this will go away? I'm not sure how to fix it otherwise.
 

Wildo6882

Well-known member
Feb 27, 2011
1,228
9
0
Visit site
So does anyone know if I just don't sync my Google calendar at all and instead move it to an icloud calendar, will this stop the double birthday notifications?
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,772
644
113
Visit site
So does anyone know if I just don't sync my Google calendar at all and instead move it to an icloud calendar, will this stop the double birthday notifications?

I'm not sure, but I would like to believe that it would.
 

Wildo6882

Well-known member
Feb 27, 2011
1,228
9
0
Visit site
Anyone figured out exactly what causes this and how to stop it? I really want to continue to use Google calendar but not if this issue persists. It's a pain!
 

Rodville

Well-known member
Jul 11, 2011
154
3
18
Visit site
For me it was Facebook. It would turn the notifications back on when one of my friends had a birthday. I would turn it off and the next birthday it would be on again. And I would turn it off and it would turn itself back on the next birthday. It would even leave the notification in the notification center even after I turned it off. I just removed Facebook from syncing anything and it seems to have solved the problem.

Q


Sent from my Nokia 6185 using Tapatalk.
 

Wildo6882

Well-known member
Feb 27, 2011
1,228
9
0
Visit site
Well I had it synced to only my Google Calendar. No Facebook or anything else was synced. I also had birthday reminders turned off. I would still get birthday alerts in the notification center and then I would get some blaring in your face alert for someone's birthday that wasn't even listed at all. I have no clue what causes it but I hate it.
 

Just_Me_D

Ambassador Team Leader, Senior Moderator
Moderator
Jan 8, 2012
59,772
644
113
Visit site
Well I had it synced to only my Google Calendar. No Facebook or anything else was synced. I also had birthday reminders turned off. I would still get birthday alerts in the notification center and then I would get some blaring in your face alert for someone's birthday that wasn't even listed at all. I have no clue what causes it but I hate it.

Do me a favor please and go to your Calendar app. Afterwards, select the 'Calendars' tab in the upper left corner. Are the calendars that are listed recognizable? Do you have more than one birthday calendar listed? Is there anything listed that shouldn't be?
 

Wildo6882

Well-known member
Feb 27, 2011
1,228
9
0
Visit site
Do me a favor please and go to your Calendar app. Afterwards, select the 'Calendars' tab in the upper left corner. Are the calendars that are listed recognizable? Do you have more than one birthday calendar listed? Is there anything listed that shouldn't be?

Nothing is there out of the ordinary. I think it has more to do with a problem syncing with my Google calendar. Even though I don't have them listed, my calendar on the computer still has the birthdays in it from my contacts that are stored in Google - although I use icloud for my contacts in iOS.
 

Latest posts

Trending Posts

Members online

Forum statistics

Threads
260,311
Messages
1,766,352
Members
441,236
Latest member
KristopherCR