Apple Maps on Mavericks won't start after OSX update / 'quit unexpectedly'

melbsteve

Well-known member
Jun 23, 2013
401
0
0
Visit site
Hi everyone,

I've got a huge problem with Maps ever since I downloaded the 10.9.1 os x update. Maps worked fine until then but now it simply won't fire up any longer. It starts jumping in the dock when I try to open it (for way too long) and then just 'quits unexpectedly'. Same happens if I then click 'reopen'. It just seems broken as of now. I'm really clueless and hope someone can maybe suggest a way to tackle the issue. I'll insert the giant text from the problem report in the hope that it is of any help...but also happy about every common sense proposal. I just want Maps back, miss it already. :( ;-)


Process: Maps [533]
Path: /Applications/Maps.app/Contents/MacOS/Maps
Identifier: com.apple.Maps
Version: 1.0 (1398.24.12)
Build Info: Navigo-1398024012000000~37
Code Type: X86-64 (Native)
Parent Process: launchd [174]
Responsible: Maps [533]
User ID: 502

Date/Time: 2014-02-21 13:05:04.225 +1100
OS Version: Mac OS X 10.9.1 (13B42)
Report Version: 11
Anonymous UUID: 8658E833-35E8-A80B-8DAF-53C74311A136


Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000600000264a00

VM Regions Near 0x600000264a00:
MALLOC_NANO 0000600000000000-0000600000200000 [ 2048K] rw-/rwx SM=PRV
--> MALLOC_NANO 0000600000200000-0000600000400000 [ 2048K] rw-/rwx SM=COW
MALLOC_NANO 0000608000000000-0000608000600000 [ 6144K] rw-/rwx SM=PRV

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 ??? 0x0000600000264a00 0 + 105553118775808
1 com.apple.AppKit 0x00007fff971b3724 -[NSCustomObject nibInstantiate] + 368
2 com.apple.AppKit 0x00007fff971b3550 -[NSIBObjectData instantiateObject:] + 309
3 com.apple.AppKit 0x00007fff971b2845 -[NSIBObjectData nibInstantiateWithOwner:topLevelObjects:] + 413
4 com.apple.AppKit 0x00007fff971a75fe loadNib + 327
5 com.apple.AppKit 0x00007fff971a6b9c +[NSBundle(NSNibLoading) _loadNibFile:nameTable:withZone:eek:wnerBundle:] + 288
6 com.apple.AppKit 0x00007fff971a698c -[NSBundle(NSNibLoading) loadNibNamed:eek:wner:topLevelObjects:] + 197
7 com.apple.AppKit 0x00007fff971a677b +[NSBundle(NSNibLoading) loadNibNamed:eek:wner:] + 357
8 com.apple.AppKit 0x00007fff971a2617 NSApplicationMain + 448
9 libdyld.dylib 0x00007fff9492c5fd start + 1

Thread 1:
0 libsystem_kernel.dylib 0x00007fff93545e6a __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x00007fff8dd1cf08 _pthread_wqthread + 330
2 libsystem_pthread.dylib 0x00007fff8dd1ffb9 start_wqthread + 13

Thread 2:: Dispatch queue: com.apple.libdispatch-manager
0 libsystem_kernel.dylib 0x00007fff93546662 kevent64 + 10
1 libdispatch.dylib 0x00007fff90d2743d _dispatch_mgr_invoke + 239
2 libdispatch.dylib 0x00007fff90d27152 _dispatch_mgr_thread + 52

Thread 3:
0 libsystem_kernel.dylib 0x00007fff93545e6a __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x00007fff8dd1cf08 _pthread_wqthread + 330
2 libsystem_pthread.dylib 0x00007fff8dd1ffb9 start_wqthread + 13

Thread 4:
0 libsystem_kernel.dylib 0x00007fff93545e6a __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x00007fff8dd1cf08 _pthread_wqthread + 330
2 libsystem_pthread.dylib 0x00007fff8dd1ffb9 start_wqthread + 13

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x0000000000000000 rbx: 0x000060000015ca90 rcx: 0x0000000000000000 rdx: 0x0000000000000000
rdi: 0x00007fff7c92ed58 rsi: 0x0000000000000052 rbp: 0x00007fff5308e660 rsp: 0x00007fff5308e630
r8: 0x000000000000003f r9: 0xffff9f7ffffa97ff r10: 0x0000000000000002 r11: 0x00007fff909bee60
r12: 0x0000000000000058 r13: 0x00007fff5308e910 r14: 0x00007fff7c92ed58 r15: 0x00007fff9682b080
rip: 0x0000600000264a00 rfl: 0x0000000000010246 cr2: 0x0000600000264a00

Logical CPU: 0
Error Code: 0x00000015
Trap Number: 14
 
Last edited:

melbsteve

Well-known member
Jun 23, 2013
401
0
0
Visit site
on my mac? I did log out and tried to launch maps with a guest account. Same result. Loads the app but crashes before it actually pops up.
 

melbsteve

Well-known member
Jun 23, 2013
401
0
0
Visit site
okay, that sounds like a plan. I'm starting to notice more issues. Calendar quits unexpectedly in the same fashion at times... it all seems much worse after the OSX update. Shouldn't have downloaded it, I'm a bit annoyed haha.
 

melbsteve

Well-known member
Jun 23, 2013
401
0
0
Visit site
To bring this to a close: thankfully the 10.9.2 update came out and fixed the whole thing. I was close to buying a new Mac after 4 years haha but I guess now I'll be able to remain patient and see what's in the pipeline this year :cool:
 

Trending Posts

Members online

Forum statistics

Threads
260,765
Messages
1,768,232
Members
441,266
Latest member
AlanD