Airport Extreme weird problem.

TFausett

Active member
Mar 24, 2011
31
0
0
Visit site
So I was having trouble with my internet the last couple of days so I got on Airport Utility and saw that my extreme needed an update so I clicked on it and this came up.

This version of AirPort Utility requires this AirPort Extreme use firmware version 7.3.1 or later. Use AirPort Utility 5.6 to update this base station. AirPort Utility 5.6 is available at AirPort Service and Support.

So I got on the apple website downloaded Airport Utility 5.7 figuring there wouldn't be a difference and it didn't change anything it still brought up that little error. So I tried reseting it and nothing still comes up with that error I have tried everything I can think of so please if anybody out there could help me that would be appreciated.:confused: