Activate iPhone Data Plan???

osensnolf

Well-known member
Jun 17, 2009
249
13
0
Visit site
I've got the phone activated via iTunes but the data plan is still not working. The phone says No Service. iTunes does not ask me to do anything else. What am I missing. I know i do not need to call ATT but I do not have an option to do anything else.

All of you have gone through this before so please provide some wisdom.

Thank you in advance.
 

iphone_aggie

Well-known member
Jun 17, 2009
131
3
0
Visit site
Well, the data plan is part of what AT&T sets up for you when you buy the iphone. Why do you say you don't need to call AT&T. It sounds like they didn't set you up correctly.
 

osensnolf

Well-known member
Jun 17, 2009
249
13
0
Visit site
Ok, I will call them. Right now, I have somewhat of a desirable situation.

I have iPhone 3G S for $199, phone service (using old sim), and no data plan but I do have WiFi access.

This is the first time I've had to active a phone through iTunes and it did not ask me or my wife about a data plan or turning the service on so that we can use our new SIM card...

Every month I hold off on the data I save $60. We both have WiFi at work and home. What are your thoughts?
 

iphone_aggie

Well-known member
Jun 17, 2009
131
3
0
Visit site
You seriously think money hungry AT&T is not going to figure out you are not paying for the data plan? What will probably happen is you'll get a huge bill for past months. However, maybe you'll get lucky, who knows.
 

osensnolf

Well-known member
Jun 17, 2009
249
13
0
Visit site
And they may track it down. If they do, I am fine with them adding the data plan as that was part of my agreement. I also agreed to pay $30/month but as of now, they have not provided that service to me without me having to request it again.

We'll see. I'm new to the process and didn't expect it to be as complicated as it has been. My other smartphones with data plans in the past have been much smoother.

Thanks for your time.
 

raksasas

Member
Jun 17, 2009
12
0
0
Visit site
I had this problem and went to AT&T. Guess what was done to fix it. A restart of the phone. Now that made me feel stupid. Cause I should have done that in the first place before going to AT&T.
 

osensnolf

Well-known member
Jun 17, 2009
249
13
0
Visit site
Hmmm... I can't say that I have tried that so I guess I will once I get home. Thank you for sharing your experience and not just reading and leaving.

PS - Is it me or does TIPB log you out very quickly? Oh well.
 

osensnolf

Well-known member
Jun 17, 2009
249
13
0
Visit site
I do that on FireFox and IE. There must be something else going on with a 3rd party application blocking cookies. At least I know it is on my end and should be something I can fix.

Thanks again.
 

Trending Posts

Forum statistics

Threads
259,683
Messages
1,764,046
Members
441,187
Latest member
Remona94B9