• Welcome to the all-new iMore Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

4S Wifi Issues???

wsm23#IM

Well-known member
Feb 22, 2010
120
4
0
Ive had my 4S for about a month or so now and I realzed the other day that it sometimes diconnects from my wifi by itself. I will look down at my phone and its connected and the next it isnt. Has anyone else noticed this issue with the 4S? :confused:
 

wats60

Member
Oct 12, 2011
20
1
0
I have the same issue! Can't keep it connected!


Sent from Stan's iPhone using Tapatalk
 

FendrGuitPlayr

Well-known member
Dec 5, 2011
257
7
0
Ive had my 4S for about a month or so now and I realzed the other day that it sometimes diconnects from my wifi by itself. I will look down at my phone and its connected and the next it isnt. Has anyone else noticed this issue with the 4S? :confused:

I haven't noticed this at all, but have heard of others with similiar complaints. Good luck!
 

ThePinkChameleon

Trusted Member
Jul 8, 2011
10,655
245
63
Couple of suggestions; 1) forget the network(wifi), reboot your iPhone and then re-add your wifi info
2) reboot your router.

See if this may help if you haven't already tried it.

other suggestion maybe to restore your iPhone also to see if that clears up the issue.
 

owlyn

Well-known member
Dec 17, 2011
68
2
0
I just had this happen, and this is what fixed it: Check your router WiFi settings to make sure that a single channel is selected, rather than "auto" (or whatever term your router uses that lets it assign channels). You want the router set to one specific channel. I doubt that it matters which one. I happened to pick channel 5.
 

Garz

Retired Moderator
Mar 9, 2009
8,176
154
0
Couple of suggestions; 1) forget the network(wifi), reboot your iPhone and then re-add your wifi info
2) reboot your router.

See if this may help if you haven't already tried it.

other suggestion maybe to restore your iPhone also to see if that clears up the issue.

I agree with this all. This will trouble shoot all areas.
 

khalid7412002

New member
Nov 11, 2011
4
0
0
I have the exact same issue and have had it since launch day. It will show connected but won't actually access the net via the browser and every app. Ive tried everything from turning off the wifi and on again, at which point it'll just hang and won't connect to the wifi again. My router channel is set to a specific, channel 6. I've rebooted the router and updated the firmware but it happens every now and then. I've forgotten the network and connected again with same results as the other methods. The only thing that works for me is to turn off the phone and restart it. It has to been my phone cause my roommates iPhone 4S has no issues with the wifi.
 

Moneymiike420

Well-known member
Nov 8, 2011
64
1
0
Just started happening to me recently at my job but the router is in basement so sometimes when I step outside for a cigarette the signal
Will jump in and out but it usually always returns to wifi automatically once or twice it didn't though
 

durbin

Member
Oct 12, 2011
16
1
0
i have the same issue since jailbreaking...and on both work and home routers. Only thing that seems to work is a full turn off of the iphone and restart....but then later that day it'll happen again. Now I only turn wifi on when i'm downloading something large...rest of the time 3G is fine.
 

jwsnj3rd

Well-known member
Mar 29, 2011
166
1
0
Me and my wife have the same issue ,well be right next to the router and it will disconnect.I took it to apple and they reset my wife's phone ,they rest her network settings seems to be ok but mine started to do it. once in a while I have to shut the wifi off and go on Verizon then back again. Then it's ok. It's weird. We noticed it first when we lost our Internet (someone unplugged the modem) but the router was still on and the 4s stayed connected to the router. Separate issue but I thought that was weird, I thought the iPhone would switch back to Verizon but I guess not.
 

saichick04

Well-known member
Nov 2, 2011
111
0
0
I had to restore to back to factory to get mine working again. But with a backup made it's all good :)

- - - Updated - - -

I had to restore to back to factory to get mine working again. But with a backup made it's all good :)
 

Ask The Community

Trending Posts

Forum statistics

Threads
255,046
Messages
1,754,334
Members
440,933
Latest member
Odonaata